summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2023-10-23 08:43:08 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-10-25 11:29:05 +0200
commitc1318bc73e25cf445ca740615b16425870ebda79 (patch)
treef831fce21ce1a1c897ba4edbaca82e458e40e917
parentc16b2293fe71e2753058fa9b653869b763e6fdc0 (diff)
downloadopenwrt-c1318bc73e25cf445ca740615b16425870ebda79.tar.gz
openwrt-c1318bc73e25cf445ca740615b16425870ebda79.tar.bz2
openwrt-c1318bc73e25cf445ca740615b16425870ebda79.zip
ixp4xx: Add a ixp4xx hardware crypto kernel module
The IXP4xx crypto module must be loaded after the rootfs is up as it depends on loading some NPE microcode from the file system. Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
-rw-r--r--package/kernel/linux/modules/crypto.mk13
-rw-r--r--target/linux/ixp4xx/Makefile1
2 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index c0ccdaa3df..dd17d868fa 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -399,6 +399,19 @@ endef
$(eval $(call KernelPackage,crypto-hw-hifn-795x))
+define KernelPackage/crypto-hw-ixp4xx
+ TITLE:=Intel IXP4xx crypto accelerator
+ DEPENDS:=@TARGET_ixp4xx +kmod-random-core +kmod-crypto-manager +kmod-crypto-authenc +kmod-crypto-des
+ KCONFIG:= \
+ CONFIG_CRYPTO_HW=y \
+ CONFIG_CRYPTO_DEV_IXP4XX
+ FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.ko
+ AUTOLOAD:=$(call AutoProbe,ixp4xx_crypto)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ixp4xx))
+
define KernelPackage/crypto-hw-padlock
TITLE:=VIA PadLock ACE with AES/SHA hw crypto module
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
index 89a1b2407b..6cd30877ee 100644
--- a/target/linux/ixp4xx/Makefile
+++ b/target/linux/ixp4xx/Makefile
@@ -21,6 +21,7 @@ KERNELNAME:=zImage dtbs
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += fconfig \
+ kmod-crypto-hw-ixp4xx \
kmod-usb-ledtrig-usbport \
kmod-leds-gpio