summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRani Hod <rani.hod@gmail.com>2023-10-08 18:18:13 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2023-10-29 19:39:54 +0100
commit62ada26de28e6c43a957b8f186ead1f45e6a5623 (patch)
tree369fb7d373e4e71cb8d3500a2074626a81fac81e
parent17465fc77ec0dbe40310548ee16352b09e2712aa (diff)
downloadopenwrt-62ada26de28e6c43a957b8f186ead1f45e6a5623.tar.gz
openwrt-62ada26de28e6c43a957b8f186ead1f45e6a5623.tar.bz2
openwrt-62ada26de28e6c43a957b8f186ead1f45e6a5623.zip
build: hide kmod-zram config unless enabled
Currently the zram default compressor choice is displayed whether or not zram is activated. Since the default choice is lzo-rle, this adds a false dependency on kmod-lib-lzo. With this patch, the choice options appear only when activating zram. Signed-off-by: Rani Hod <rani.hod@gmail.com>
-rw-r--r--package/kernel/linux/modules/other.mk20
1 files changed, 11 insertions, 9 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 055dca6818..face579472 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1046,31 +1046,33 @@ define KernelPackage/zram/description
endef
define KernelPackage/zram/config
- choice
- prompt "ZRAM Default compressor"
- default ZRAM_DEF_COMP_LZORLE
+ if PACKAGE_kmod-zram
+ choice
+ prompt "ZRAM Default compressor"
+ default ZRAM_DEF_COMP_LZORLE
- config ZRAM_DEF_COMP_LZORLE
+ config ZRAM_DEF_COMP_LZORLE
bool "lzo-rle"
select PACKAGE_kmod-lib-lzo
- config ZRAM_DEF_COMP_LZO
+ config ZRAM_DEF_COMP_LZO
bool "lzo"
select PACKAGE_kmod-lib-lzo
- config ZRAM_DEF_COMP_LZ4
+ config ZRAM_DEF_COMP_LZ4
bool "lz4"
select PACKAGE_kmod-lib-lz4
- config ZRAM_DEF_COMP_LZ4HC
+ config ZRAM_DEF_COMP_LZ4HC
bool "lz4-hc"
select PACKAGE_kmod-lib-lz4hc
- config ZRAM_DEF_COMP_ZSTD
+ config ZRAM_DEF_COMP_ZSTD
bool "zstd"
select PACKAGE_kmod-lib-zstd
- endchoice
+ endchoice
+ endif
endef
$(eval $(call KernelPackage,zram))