summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Kępień <openwrt@kempniu.pl>2024-05-13 19:26:15 +0200
committerRobert Marko <robimarko@gmail.com>2024-06-05 17:03:24 +0200
commit7e2a3af8c4cae2ba4d770db2f7a3e068815d163f (patch)
tree59090ba3cf44b41bcdf2bc8acdc09ecb3e55b33b
parent683a35098ff603e073acf13e124bfc0708852c51 (diff)
downloadopenwrt-7e2a3af8c4cae2ba4d770db2f7a3e068815d163f.tar.gz
openwrt-7e2a3af8c4cae2ba4d770db2f7a3e068815d163f.tar.bz2
openwrt-7e2a3af8c4cae2ba4d770db2f7a3e068815d163f.zip
tools: add Yafut to enable creating Yaffs filesystem images
The Yafut tool has so far been used to update the kernel on devices with NAND flash via MTD character devices. Recent upstream updates extended the tool with limited support for working with filesystem images stored in regular files. This enables Yafut to be used for preparing a Yaffs filesystem image for a device with NOR flash on a build host and subsequently flashing it to the target device without using Yafut itself. Add Yafut to tools/ so that it can be compiled and run on the host building OpenWRT. Signed-off-by: Michał Kępień <openwrt@kempniu.pl> Link: https://github.com/openwrt/openwrt/pull/13453 Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--tools/yafut/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tools/yafut/Makefile b/tools/yafut/Makefile
new file mode 100644
index 0000000000..a7e36e5175
--- /dev/null
+++ b/tools/yafut/Makefile
@@ -0,0 +1,20 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=yafut
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL=https://github.com/kempniu/yafut.git
+PKG_MIRROR_HASH:=9cc6b4c485ce16d44b67ebf79e8bee1e07aecde112da739cf33e8714ac3842e7
+PKG_SOURCE_DATE:=2024-05-13
+PKG_SOURCE_VERSION:=2b45baaf1cced47af8f22dd3acbf1df2f04c7510
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+CMAKE_INSTALL:=1
+
+$(eval $(call HostBuild))