summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2024-03-01 22:51:25 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2024-04-14 17:38:09 +0200
commit87d7fa8885e0bb09ee088bdcc1060ac99699d39e (patch)
tree45488df86d03ec5d604f119e7fd00556197a6e27
parente609b7486fbd22c3e48194c9182f948f21b8a204 (diff)
downloadopenwrt-87d7fa8885e0bb09ee088bdcc1060ac99699d39e.tar.gz
openwrt-87d7fa8885e0bb09ee088bdcc1060ac99699d39e.tar.bz2
openwrt-87d7fa8885e0bb09ee088bdcc1060ac99699d39e.zip
toolchain/musl: Update to 1.2.5
Update musl C library to 1.2.5 This release adds extension functions statx and preadv2/pwritev2, with fallback implementations for older kernels, and adds two new ports: loongarch64 and riscv32. Minor changes to the printf family of functions have been made for conformance to new standards interpretations/requirements. TLSDESC support for riscv64 has also been added. Bugs fixed include some DNS issues related to new TCP fallback functionality, several rare race conditions, potentially incorrect return value when glob aborts, and several signifiant arch-specific bugs affecting TLSDESC on arm, riscv64 icache flushing, and sh sigsetjmp and dlsym RTLD_NEXT. 1.2.5 release notes: new features: - statx function (linux extension; via syscall and fallback using fstatat) - clone function is now usable and gives _Fork-like consistency in child - statvfs now provides f_type result - preadv2 and pwritev2 (linux extension) syscall wrappers - riscv64 TLSDESC support new ports: - loongarch64 - riscv32 compatibility: - DNS resolver can now handle answers with long CNAME chains - string.h no longer provides (C23-incompat) non-prototype decl of basename - fstatat statx backend now matches stat syscall non-automounting behavior - mntent interfaces now handle escaped whitespace in paths/options standards updates: - printf %lc of nul wchar now produces output - snprintf and swprintf no longer fail on n > INT_MAX - ppoll is now exposed in default feature profile bugs fixed: - some long DNS answers were wrongly rejected despite new TCP support - glob could wrongly return GLOB_NOMATCH if aborted before any matches - multithreaded set*id could malfunction from thread sequencing logic bug - certain use of threads after fork could deadlock thread-list lock - posix_spawn child could deadlock in race with async parent death - mbrtowc return value was wrong if argument n exceeded UINT_MAX - 80-bit extended acoshl and powl got some corner cases wrong - syslog incorrectly generated localized timestamps arch-specific bugs fixed: - arm (32-bit) TLSDESC malfunctioned due to addends being processed wrong - riscv64 icache flush operation was non-functional - sh sigsetjmp failed to properly restore call-saved register r8 on return - sh dlsym RTLD_NEXT did not identify calling module correctly Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi> [Removed patch adding basename hack again] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--toolchain/musl/common.mk4
-rw-r--r--toolchain/musl/patches/900-iconv_size_hack.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/toolchain/musl/common.mk b/toolchain/musl/common.mk
index 94444eaf75..35bdfd184b 100644
--- a/toolchain/musl/common.mk
+++ b/toolchain/musl/common.mk
@@ -8,12 +8,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk
PKG_NAME:=musl
-PKG_VERSION:=1.2.4
+PKG_VERSION:=1.2.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://musl.libc.org/releases/
-PKG_HASH:=7a35eae33d5372a7c0da1188de798726f68825513b7ae3ebe97aaaa52114f039
+PKG_HASH:=a9a118bbe84d8764da0ea0d28b3ab3fae8477fc7e4085d90102b8596fc7c75e4
PKG_CPE_ID:=cpe:/a:musl-libc:musl
LIBC_SO_VERSION:=$(PKG_VERSION)
diff --git a/toolchain/musl/patches/900-iconv_size_hack.patch b/toolchain/musl/patches/900-iconv_size_hack.patch
index 461a204a4c..ad1dc4b109 100644
--- a/toolchain/musl/patches/900-iconv_size_hack.patch
+++ b/toolchain/musl/patches/900-iconv_size_hack.patch
@@ -6,7 +6,7 @@
"ucs2\0\0\314"
+#ifdef FULL_ICONV
"eucjp\0\0\320"
- "shiftjis\0sjis\0\0\321"
+ "shiftjis\0sjis\0cp932\0\0\321"
"iso2022jp\0\0\322"
@@ -56,6 +57,7 @@ static const unsigned char charmaps[] =
"gb2312\0\0\332"