summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomanov Danila <pervokur@gmail.com>2024-10-21 21:34:34 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2024-11-23 15:42:24 +0100
commitd8a9669093359d60f4d6f183b58a22f24cf01731 (patch)
tree6b21d94aea116d6ccb0488499b8553564307fa45
parent75af6a0d736a696ca726cb44d813791858c29f0c (diff)
downloadopenwrt-d8a9669093359d60f4d6f183b58a22f24cf01731.tar.gz
openwrt-d8a9669093359d60f4d6f183b58a22f24cf01731.tar.bz2
openwrt-d8a9669093359d60f4d6f183b58a22f24cf01731.zip
mediatek: change Routerich AX3000 ubi size
All new routers are shipped with ubi size 112MB since early September. Bootloader update required (ask vendor , see wiki) These partitions weren't used: firmware_backup zrsave config2 Signed-off-by: Romanov Danila <pervokur@gmail.com> Link: https://github.com/openwrt/openwrt/pull/16686 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--target/linux/mediatek/dts/mt7981b-routerich-ax3000.dts20
-rw-r--r--target/linux/mediatek/filogic/base-files/etc/board.d/05_compat-version3
-rw-r--r--target/linux/mediatek/image/filogic.mk5
3 files changed, 9 insertions, 19 deletions
diff --git a/target/linux/mediatek/dts/mt7981b-routerich-ax3000.dts b/target/linux/mediatek/dts/mt7981b-routerich-ax3000.dts
index dfe44843b9..aa6a15ee1d 100644
--- a/target/linux/mediatek/dts/mt7981b-routerich-ax3000.dts
+++ b/target/linux/mediatek/dts/mt7981b-routerich-ax3000.dts
@@ -226,25 +226,7 @@
partition@580000 {
label = "ubi";
- reg = <0x580000 0x4000000>;
- };
-
- partition@4580000 {
- label = "firmware_backup";
- reg = <0x4580000 0x2000000>;
- read-only;
- };
-
- partition@6580000 {
- label = "zrsave";
- reg = <0x6580000 0x100000>;
- read-only;
- };
-
- partition@6680000 {
- label = "config2";
- reg = <0x6680000 0x100000>;
- read-only;
+ reg = <0x580000 0x7000000>;
};
};
};
diff --git a/target/linux/mediatek/filogic/base-files/etc/board.d/05_compat-version b/target/linux/mediatek/filogic/base-files/etc/board.d/05_compat-version
index d0cfd8f0a1..9b704b983c 100644
--- a/target/linux/mediatek/filogic/base-files/etc/board.d/05_compat-version
+++ b/target/linux/mediatek/filogic/base-files/etc/board.d/05_compat-version
@@ -8,6 +8,9 @@ case "$(board_name)" in
bananapi,bpi-r3)
ucidef_set_compat_version "1.2"
;;
+ routerich,ax3000)
+ ucidef_set_compat_version "1.1"
+ ;;
esac
board_config_flush
diff --git a/target/linux/mediatek/image/filogic.mk b/target/linux/mediatek/image/filogic.mk
index 739fd54308..cb5c102b1e 100644
--- a/target/linux/mediatek/image/filogic.mk
+++ b/target/linux/mediatek/image/filogic.mk
@@ -1173,6 +1173,11 @@ define Device/routerich_ax3000
DEVICE_PACKAGES := kmod-mt7915e kmod-mt7981-firmware mt7981-wo-firmware kmod-usb3
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
SUPPORTED_DEVICES += mediatek,mt7981-spim-snand-rfb
+ DEVICE_COMPAT_VERSION := 1.1
+ DEVICE_COMPAT_MESSAGE := Partition layout has been changed. Bootloader MUST be \
+ upgraded to avoid data corruption and getting bricked. \
+ Please, contact your vendor and follow the guide: \
+ https://openwrt.org/toh/routerich/ax3000#web_ui_method
endef
TARGET_DEVICES += routerich_ax3000