summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Richard <thomas.richard@bootlin.com>2024-10-25 15:21:57 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2024-11-23 15:53:21 +0100
commite606366a2e018e0a3b25e3dd4b3a937bb53c70e1 (patch)
tree342b6c553ba08322d138095002b931c22ccec4f0
parentff96bd84ce0bae633007cf0de82d69796cf3508a (diff)
downloadopenwrt-e606366a2e018e0a3b25e3dd4b3a937bb53c70e1.tar.gz
openwrt-e606366a2e018e0a3b25e3dd4b3a937bb53c70e1.tar.bz2
openwrt-e606366a2e018e0a3b25e3dd4b3a937bb53c70e1.zip
kernel: package snd-soc-dmic driver
It is needed for the stm32/stm32mp1 subtarget. Signed-off-by: Thomas Richard <thomas.richard@bootlin.com> Link: https://github.com/openwrt/openwrt/pull/16716 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--package/kernel/linux/modules/sound.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 623f65ac59..f3e44e01ee 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -314,6 +314,17 @@ endef
$(eval $(call KernelPackage,sound-soc-spdif))
+define KernelPackage/sound-soc-dmic
+ TITLE:=Generic Digital Microphone CODEC
+ KCONFIG:=CONFIG_SND_SOC_DMIC
+ FILES:=$(LINUX_DIR)/sound/soc/codecs/snd-soc-dmic.ko
+ AUTOLOAD:=$(call AutoProbe,snd-soc-dmic)
+ $(call AddDepends/sound,+kmod-sound-soc-core)
+endef
+
+$(eval $(call KernelPackage,sound-soc-dmic))
+
+
define KernelPackage/pcspkr
DEPENDS:=@TARGET_x86 +kmod-input-core
TITLE:=PC speaker support