summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-10-07 21:33:51 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-21 12:35:56 +0100
commit45fefa0459d53d87e5f4c0aae2a2f123ee624e6b (patch)
treebb2e9dffb5d8b3d72e394158390ca14a1cca5ad4
parentb0d99e32dbb256fe165816a13fe353ef725eebd5 (diff)
downloadopenwrt-45fefa0459d53d87e5f4c0aae2a2f123ee624e6b.tar.gz
openwrt-45fefa0459d53d87e5f4c0aae2a2f123ee624e6b.tar.bz2
openwrt-45fefa0459d53d87e5f4c0aae2a2f123ee624e6b.zip
ramips: set uImage name of WeVO 11AC NAS and W2914NS v2
The stock firmware and bootloader only accept uImage with names that match certain patterns. This patch enables OpenWrt installation from stock firmware without having to reflash the bootloader or access the UART console. Installation via web interface: 1. Flash **initramfs** image through the stock web interface. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Signed-off-by: Sungbo Eo <mans0n@gorani.run> (cherry picked from commit 19800ac095f6ddbba03ccab08e5197b1eec4a49e) [backported] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--target/linux/ramips/image/mt7621.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index c8de8bd5ff..a352ca21d7 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -44,6 +44,7 @@ endef
define Device/11acnas
DTS := 11ACNAS
IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ UIMAGE_NAME := 11AC-NAS-Router(0.0.0)
DEVICE_TITLE := WeVO 11AC NAS Router
DEVICE_PACKAGES := kmod-mt7603 kmod-usb3 kmod-usb-ledtrig-usbport wpad-mini
endef
@@ -334,6 +335,7 @@ TARGET_DEVICES += vr500
define Device/w2914nsv2
DTS := W2914NSV2
IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ UIMAGE_NAME := W2914NS-V2(0.0.0)
DEVICE_TITLE := WeVO W2914NS v2
DEVICE_PACKAGES := \
kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-mini