summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-04-04 09:20:08 +0100
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-05-04 16:22:39 +0100
commit7ebc51a57fd7cccada939137b66bcdce965badea (patch)
treefe3af981c0f8bfe46e5e00bb89d1641b4f4a1913
parentf77708d4a592a0d77b878515bde9674978a75124 (diff)
downloadopenwrt-7ebc51a57fd7cccada939137b66bcdce965badea.tar.gz
openwrt-7ebc51a57fd7cccada939137b66bcdce965badea.tar.bz2
openwrt-7ebc51a57fd7cccada939137b66bcdce965badea.zip
umdns: suppress address-of-packed-member warning
gcc 8 & 9 appear to be more picky with regards access alignment to packed structures, leading to this warning in dns.c: dns.c:261:2: error: converting a packed ‘struct dns_question’ pointer (alignment 1) to a ‘uint16_t’ {aka ‘short unsigned int’} pointer (alignment 2) may result in an unaligned pointer value [-Werror=address-of-packed-member] 261 | uint16_t *swap = (uint16_t *) q; Work around what I think is a false positive by turning the warning off. Not ideal, but not quite as not ideal as build failure. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> (cherry picked from commit 02640f014719a994e2e538b2cb6376a189cd39de)
-rw-r--r--package/network/services/umdns/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/umdns/Makefile b/package/network/services/umdns/Makefile
index ffbc3fed35..7dbbea322a 100644
--- a/package/network/services/umdns/Makefile
+++ b/package/network/services/umdns/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=umdns
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL=$(PROJECT_GIT)/project/mdnsd.git
PKG_SOURCE_PROTO:=git
@@ -30,7 +30,7 @@ define Package/umdns
DEPENDS:=+libubox +libubus +libblobmsg-json
endef
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include -Wno-address-of-packed-member
define Package/umdns/conffiles
/etc/config/umdns