summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Stefaniak <pstef@freebsd.org>2020-08-09 00:38:21 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-11 01:18:04 +0200
commit95dc2f5257c67c98816de1d88cdb29dd26be1d5e (patch)
treeef843475207185dfd857ad8d984a6359799bb82f
parent3667693830d54a9a4fdbb9eef802331a9b5f8d37 (diff)
downloadopenwrt-95dc2f5257c67c98816de1d88cdb29dd26be1d5e.tar.gz
openwrt-95dc2f5257c67c98816de1d88cdb29dd26be1d5e.tar.bz2
openwrt-95dc2f5257c67c98816de1d88cdb29dd26be1d5e.zip
tools/cmake: fix typo in parallel make patch
The variable in the case argument was mistyped, so the case always checked against an empty string and never matched. Fix the variable name. Add a PKG_RELEASE to Makefile so we can bump it. Fixes: d6de31310cc1 ("cmake: restore parallel build support for bootstrap") Signed-off-by: Piotr Stefaniak <pstef@freebsd.org> [add commit message, add PKG_RELEASE, fix commit title, add Fixes:] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit e27fbae63c3436ce5588ca06b78ea88c7a316fee)
-rw-r--r--tools/cmake/Makefile1
-rw-r--r--tools/cmake/patches/130-bootstrap_parallel_make_flag.patch2
2 files changed, 2 insertions, 1 deletions
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index 3278a48188..288e2d3856 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -8,6 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
PKG_VERSION:=3.11.4
+PKG_RELEASE:=2
PKG_CPE_ID:=cpe:/a:kitware:cmake
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
index 1fb0ebeaac..3acaec5821 100644
--- a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
+++ b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
@@ -5,7 +5,7 @@
cmake_original_make_flags="${cmake_make_flags}"
if [ "x${cmake_parallel_make}" != "x" ]; then
- cmake_make_flags="${cmake_make_flags} -j ${cmake_parallel_make}"
-+ case "$cmake_paralle_make" in
++ case "$cmake_parallel_make" in
+ [0-9]*) cmake_parallel_make="-j ${cmake_parallel_make}";;
+ esac
+ cmake_make_flags="${cmake_make_flags} ${cmake_parallel_make}"