summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-03-24 06:52:37 +0100
committerPetr Štetiar <ynezz@true.cz>2022-04-05 22:09:35 +0200
commit058c2347c51f4989c325bba03d8a0af19640dced (patch)
tree9a9309e2e5ef8fb890b2d1d0374e946ddc05f218
parentd39a6c67dcb487ad7d0d0dc8262cff3fcb3e8d39 (diff)
downloadopenwrt-058c2347c51f4989c325bba03d8a0af19640dced.tar.gz
openwrt-058c2347c51f4989c325bba03d8a0af19640dced.tar.bz2
openwrt-058c2347c51f4989c325bba03d8a0af19640dced.zip
imagebuilder: fix broken image generation with external targets
When using external targets there is a symlink being created for the target under target/linux which then becomes dangling under Image Builder. Fix it by dereferencing the possible symlink. Tested on IB with external target, ipq40xx and mvebu. Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 621f39d1f438bf95dbae667c575926fa16a6d797) (cherry picked from commit ec9af870f3278f75549836b469baefa260e2ed41) (cherry picked from commit 3008f1f441a41e162311cee1ccadfdaaec1581c1)
-rw-r--r--target/imagebuilder/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index f1f25fc7c4..4246bed1ea 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -57,7 +57,7 @@ else
find $(wildcard $(PACKAGE_SUBDIRS)) -type f -name '*.ipk' -exec $(CP) {} $(PKG_BUILD_DIR)/packages/ \;
endif
- $(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
+ $(CP) -L $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
if [ -d $(TOPDIR)/staging_dir/host/lib/grub ]; then \
$(CP) $(TOPDIR)/staging_dir/host/lib/grub/ $(PKG_BUILD_DIR)/staging_dir/host/lib; \
fi