summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-03-29 18:13:56 -0700
committerBaptiste Jonglez <git@bitsofnetworks.org>2021-05-08 12:50:49 +0200
commit5bec393fcb34236a6fcdb4b9adaf6ba755ef7677 (patch)
tree2db6af311877daf81ea9c19f94ffd890cbcf7d2b
parenta2728a806a055f38d7451b56681787e362b1eb25 (diff)
downloadopenwrt-5bec393fcb34236a6fcdb4b9adaf6ba755ef7677.tar.gz
openwrt-5bec393fcb34236a6fcdb4b9adaf6ba755ef7677.tar.bz2
openwrt-5bec393fcb34236a6fcdb4b9adaf6ba755ef7677.zip
prereq-build: test for perl's Data::Dumper
Required for installation of autoconf: make[5]: Entering directory `/openwrt/build_dir/host/autoconf-2.69' Making all in bin make[6]: Entering directory `/openwrt/build_dir/host/autoconf-2.69/bin' autom4te_perllibdir='..'/lib AUTOM4TE_CFG='../lib/autom4te.cfg' ../bin/autom4te -B '..'/lib -B '..'/lib --language M4sh --cache '' --melt ./autoconf.as -o autoconf.in Can't locate Data/Dumper.pm in @INC (@INC contains: ../lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at ../lib/Autom4te/C4che.pm line 33. BEGIN failed--compilation aborted at ../lib/Autom4te/C4che.pm line 33. Compilation failed in require at ../bin/autom4te line 40. BEGIN failed--compilation aborted at ../bin/autom4te line 40. make[6]: *** [autoconf.in] Error 2 Signed-off-by: Rosen Penev <rosenp@gmail.com> (cherry picked from commit dc467eac38f2447b652b6680cf4af75b05fd6cd2)
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 4528f87391..54ed0e6f90 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -64,6 +64,10 @@ else
zlib_link_flags := -lz
endif
+$(eval $(call TestHostCommand,perl-data-dumper, \
+ Please install the Perl Data::Dumper module, \
+ perl -MData::Dumper -e 1))
+
$(eval $(call TestHostCommand,perl-thread-queue, \
Please install the Perl Thread::Queue module, \
perl -MThread::Queue -e 1))