summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gyurgyik <matthew@gyurgyik.io>2020-11-13 11:21:29 -0800
committerPaul Spooren <mail@aparcar.org>2022-02-27 14:02:27 +0100
commit5ecc7ead48783136569a541d59398e08767fd8bc (patch)
tree089c6153b777bc5e3d0666096551463d8821d331
parentf49eec6335ea9c0d652e8525a04c166f1fe3eedd (diff)
downloadopenwrt-5ecc7ead48783136569a541d59398e08767fd8bc.tar.gz
openwrt-5ecc7ead48783136569a541d59398e08767fd8bc.tar.bz2
openwrt-5ecc7ead48783136569a541d59398e08767fd8bc.zip
imagebuilder: fix partition signature
When building images with the imagebuilder, the partition signature never changes. The signature is generated by hashing SOURCE_DATE_EPOCH and LINUX_VERMAGIC which are undefined. Prepopulate these variables, as done by the SDK. Signed-off-by: Matthew Gyurgyik <matthew@gyurgyik.io> (cherry picked from commit aab36200e7eb539afb18df74476132f4750a9f0b)
-rw-r--r--target/imagebuilder/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 05c7cf3318..f1f25fc7c4 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -77,6 +77,8 @@ endif
$(CP) -L $(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/dts/* $(IB_DTSDIR); \
fi
$(SED) 's,^# REVISION:=.*,REVISION:=$(REVISION),g' $(PKG_BUILD_DIR)/include/version.mk
+ $(SED) 's,^# SOURCE_DATE_EPOCH:=.*,SOURCE_DATE_EPOCH:=$(SOURCE_DATE_EPOCH),g' $(PKG_BUILD_DIR)/include/version.mk
+ $(SED) '/LINUX_VERMAGIC:=/ { s,unknown,$(LINUX_VERMAGIC),g }' $(PKG_BUILD_DIR)/include/kernel.mk
find $(PKG_BUILD_DIR) -name CVS -o -name .git -o -name .svn \
| $(XARGS) rm -rf
$(INSTALL_DIR) $(IB_IDIR)