summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-13 16:56:53 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-24 18:05:02 +0100
commit86aeac4fc98f42ac0ce7e0dcf1cb240e16b28f8f (patch)
tree529fb147f2a6e2e1dcdaab4ffd1d0b680426d309
parente9c0c5021cca6e5982a9f6a1719897463c93a28b (diff)
downloadopenwrt-86aeac4fc98f42ac0ce7e0dcf1cb240e16b28f8f.tar.gz
openwrt-86aeac4fc98f42ac0ce7e0dcf1cb240e16b28f8f.tar.bz2
openwrt-86aeac4fc98f42ac0ce7e0dcf1cb240e16b28f8f.zip
base-files: source functions.sh in /lib/functions/system.sh
The file /lib/functions/system.sh depends on find_mtd_index() and find_mtd_part() located in /lib/function.sh, so let's source that file. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (backported from commit ae636effd24a7637cefca58a143063f395c82d05)
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/lib/functions/system.sh2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index f2af97f7e6..9df5b860f8 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=base-files
-PKG_RELEASE:=204.2
+PKG_RELEASE:=204.3
PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/functions/system.sh b/package/base-files/files/lib/functions/system.sh
index dceb66a851..e97d00c144 100644
--- a/package/base-files/files/lib/functions/system.sh
+++ b/package/base-files/files/lib/functions/system.sh
@@ -1,5 +1,7 @@
# Copyright (C) 2006-2013 OpenWrt.org
+. /lib/functions.sh
+
get_mac_binary() {
local path="$1"
local offset="$2"