summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-03-28 11:39:18 +0200
committerPetr Štetiar <ynezz@true.cz>2022-03-28 11:39:18 +0200
commitb24905c38a8acc337a08c116b343b6ccc3ba861e (patch)
tree0657dfe3644d945f57d2df11d17ae75046dfecdc
parenta518a4f7863094f9b7f76707c011a187b7df4f5f (diff)
downloadopenwrt-b24905c38a8acc337a08c116b343b6ccc3ba861e.tar.gz
openwrt-b24905c38a8acc337a08c116b343b6ccc3ba861e.tar.bz2
openwrt-b24905c38a8acc337a08c116b343b6ccc3ba861e.zip
kernel: bump 4.14 to 4.14.274
All patches refreshed automagically without conflicts. Run tested on ipq40xx/glinet-b1300 and mvebu/turris-omnia. Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch2
-rw-r--r--target/linux/generic/hack-4.14/902-debloat_proc.patch2
3 files changed, 4 insertions, 4 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 73bbcbb04e..d0ac3b2ee1 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-4.14 = .273
+LINUX_VERSION-4.14 = .274
-LINUX_KERNEL_HASH-4.14.273 = 1bfd1b320a7167cf6cf0a8a1e9f7f1e5932b997c9041507c5aaff80b8dacbc2d
+LINUX_KERNEL_HASH-4.14.274 = 2b42538fcb88df5113e1797ab18252ac6ba876f1d13c83af6ea7c6430b0f7fad
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch b/target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
index 1bb30ab6ca..82afb03d29 100644
--- a/target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
+++ b/target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
@@ -55,7 +55,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
rwlock_t sk_callback_lock;
--- a/net/core/sock.c
+++ b/net/core/sock.c
-@@ -2791,6 +2791,7 @@ void sock_init_data(struct socket *sock,
+@@ -2788,6 +2788,7 @@ void sock_init_data(struct socket *sock,
sk->sk_max_pacing_rate = ~0U;
sk->sk_pacing_rate = ~0U;
diff --git a/target/linux/generic/hack-4.14/902-debloat_proc.patch b/target/linux/generic/hack-4.14/902-debloat_proc.patch
index e6b761d3c0..a517b6fa6a 100644
--- a/target/linux/generic/hack-4.14/902-debloat_proc.patch
+++ b/target/linux/generic/hack-4.14/902-debloat_proc.patch
@@ -327,7 +327,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/net/core/sock.c
+++ b/net/core/sock.c
-@@ -3430,6 +3430,8 @@ static __net_initdata struct pernet_oper
+@@ -3427,6 +3427,8 @@ static __net_initdata struct pernet_oper
static int __init proto_init(void)
{