summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-04-05 14:20:05 +0200
committerPetr Štetiar <ynezz@true.cz>2022-04-05 14:20:05 +0200
commitd39a6c67dcb487ad7d0d0dc8262cff3fcb3e8d39 (patch)
treea3018e9a7a848e1305150e0dea94dfc37c7c90a6
parent9aa35fada6522189202c324dd9a97672460b0e4a (diff)
downloadopenwrt-d39a6c67dcb487ad7d0d0dc8262cff3fcb3e8d39.tar.gz
openwrt-d39a6c67dcb487ad7d0d0dc8262cff3fcb3e8d39.tar.bz2
openwrt-d39a6c67dcb487ad7d0d0dc8262cff3fcb3e8d39.zip
kernel: bump 4.14 to 4.14.275
All patches refreshed automagically without conflicts. Run tested on ipq40xx/glinet-b1300 and mvebu/turris-omnia. Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/bcm53xx/patches-4.14/905-BCM53573-minor-hacks.patch2
-rw-r--r--target/linux/sunxi/patches-4.14/031-arm64-Implement-arch_counter_get_cntpct-to-read-the-.patch8
-rw-r--r--target/linux/sunxi/patches-4.14/100-clocksource-drivers-arch_timer-Workaround-for-Allwin.patch6
4 files changed, 10 insertions, 10 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index d0ac3b2ee1..1d97de0ec0 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-4.14 = .274
+LINUX_VERSION-4.14 = .275
-LINUX_KERNEL_HASH-4.14.274 = 2b42538fcb88df5113e1797ab18252ac6ba876f1d13c83af6ea7c6430b0f7fad
+LINUX_KERNEL_HASH-4.14.275 = 100a9960fb2d8e079c9feeef640715a7fb749ed728a57e427f9e2443212e58f9
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/bcm53xx/patches-4.14/905-BCM53573-minor-hacks.patch b/target/linux/bcm53xx/patches-4.14/905-BCM53573-minor-hacks.patch
index 4762505708..a0a893a31f 100644
--- a/target/linux/bcm53xx/patches-4.14/905-BCM53573-minor-hacks.patch
+++ b/target/linux/bcm53xx/patches-4.14/905-BCM53573-minor-hacks.patch
@@ -61,7 +61,7 @@ Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
#include <linux/clockchips.h>
#include <linux/clocksource.h>
#include <linux/interrupt.h>
-@@ -845,6 +846,16 @@ static void arch_timer_of_configure_rate
+@@ -860,6 +861,16 @@ static void arch_timer_of_configure_rate
if (of_property_read_u32(np, "clock-frequency", &arch_timer_rate))
arch_timer_rate = rate;
diff --git a/target/linux/sunxi/patches-4.14/031-arm64-Implement-arch_counter_get_cntpct-to-read-the-.patch b/target/linux/sunxi/patches-4.14/031-arm64-Implement-arch_counter_get_cntpct-to-read-the-.patch
index 60f0cb6c9b..937d3e591e 100644
--- a/target/linux/sunxi/patches-4.14/031-arm64-Implement-arch_counter_get_cntpct-to-read-the-.patch
+++ b/target/linux/sunxi/patches-4.14/031-arm64-Implement-arch_counter_get_cntpct-to-read-the-.patch
@@ -84,7 +84,7 @@ Signed-off-by: Christoffer Dall <christoffer.dall@linaro.org>
static u64 notrace arm64_858921_read_cntvct_el0(void)
{
u64 old, new;
-@@ -346,6 +365,7 @@ static const struct arch_timer_erratum_w
+@@ -353,6 +372,7 @@ static const struct arch_timer_erratum_w
.desc = "Freescale erratum a005858",
.read_cntp_tval_el0 = fsl_a008585_read_cntp_tval_el0,
.read_cntv_tval_el0 = fsl_a008585_read_cntv_tval_el0,
@@ -92,7 +92,7 @@ Signed-off-by: Christoffer Dall <christoffer.dall@linaro.org>
.read_cntvct_el0 = fsl_a008585_read_cntvct_el0,
.set_next_event_phys = erratum_set_next_event_tval_phys,
.set_next_event_virt = erratum_set_next_event_tval_virt,
-@@ -358,6 +378,7 @@ static const struct arch_timer_erratum_w
+@@ -365,6 +385,7 @@ static const struct arch_timer_erratum_w
.desc = "HiSilicon erratum 161010101",
.read_cntp_tval_el0 = hisi_161010101_read_cntp_tval_el0,
.read_cntv_tval_el0 = hisi_161010101_read_cntv_tval_el0,
@@ -100,7 +100,7 @@ Signed-off-by: Christoffer Dall <christoffer.dall@linaro.org>
.read_cntvct_el0 = hisi_161010101_read_cntvct_el0,
.set_next_event_phys = erratum_set_next_event_tval_phys,
.set_next_event_virt = erratum_set_next_event_tval_virt,
-@@ -368,6 +389,7 @@ static const struct arch_timer_erratum_w
+@@ -375,6 +396,7 @@ static const struct arch_timer_erratum_w
.desc = "HiSilicon erratum 161010101",
.read_cntp_tval_el0 = hisi_161010101_read_cntp_tval_el0,
.read_cntv_tval_el0 = hisi_161010101_read_cntv_tval_el0,
@@ -108,7 +108,7 @@ Signed-off-by: Christoffer Dall <christoffer.dall@linaro.org>
.read_cntvct_el0 = hisi_161010101_read_cntvct_el0,
.set_next_event_phys = erratum_set_next_event_tval_phys,
.set_next_event_virt = erratum_set_next_event_tval_virt,
-@@ -378,6 +400,7 @@ static const struct arch_timer_erratum_w
+@@ -385,6 +407,7 @@ static const struct arch_timer_erratum_w
.match_type = ate_match_local_cap_id,
.id = (void *)ARM64_WORKAROUND_858921,
.desc = "ARM erratum 858921",
diff --git a/target/linux/sunxi/patches-4.14/100-clocksource-drivers-arch_timer-Workaround-for-Allwin.patch b/target/linux/sunxi/patches-4.14/100-clocksource-drivers-arch_timer-Workaround-for-Allwin.patch
index 6da300312f..79e94c6fd2 100644
--- a/target/linux/sunxi/patches-4.14/100-clocksource-drivers-arch_timer-Workaround-for-Allwin.patch
+++ b/target/linux/sunxi/patches-4.14/100-clocksource-drivers-arch_timer-Workaround-for-Allwin.patch
@@ -173,7 +173,7 @@ Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
select TIMER_OF if OF
--- a/drivers/clocksource/arm_arch_timer.c
+++ b/drivers/clocksource/arm_arch_timer.c
-@@ -317,6 +317,48 @@ static u64 notrace arm64_858921_read_cnt
+@@ -324,6 +324,48 @@ static u64 notrace arm64_1188873_read_cn
}
#endif
@@ -222,8 +222,8 @@ Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
#ifdef CONFIG_ARM_ARCH_TIMER_OOL_WORKAROUND
DEFINE_PER_CPU(const struct arch_timer_erratum_workaround *,
timer_unstable_counter_workaround);
-@@ -404,6 +446,19 @@ static const struct arch_timer_erratum_w
- .read_cntvct_el0 = arm64_858921_read_cntvct_el0,
+@@ -419,6 +461,19 @@ static const struct arch_timer_erratum_w
+ .read_cntvct_el0 = arm64_1188873_read_cntvct_el0,
},
#endif
+#ifdef CONFIG_SUN50I_ERRATUM_UNKNOWN1