summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBas Mevissen <abuse@basmevissen.nl>2021-04-20 01:08:19 +0200
committerBaptiste Jonglez <git@bitsofnetworks.org>2021-05-08 12:51:54 +0200
commitded3ad3c2f218c06968d1535aa8347646dd731f5 (patch)
tree07ca99be12dfe88e78f80da90bcf55962d63d329
parent5bec393fcb34236a6fcdb4b9adaf6ba755ef7677 (diff)
downloadopenwrt-ded3ad3c2f218c06968d1535aa8347646dd731f5.tar.gz
openwrt-ded3ad3c2f218c06968d1535aa8347646dd731f5.tar.bz2
openwrt-ded3ad3c2f218c06968d1535aa8347646dd731f5.zip
Extend checks on build prerequisites for building OpenWRT core
OpenWRT requires a number of Perl modules to be installed. It wasn't checking on all of them. This patch adds checks for Perl FindBin, File::Copy, File::Compare and Thread::Queue modules. Failing to install these, will have the build break at some point. By adding these to the prereq-build.mk script, they are checked on forehand. Tested on a Fedora 33 and 34 (beta) that was freshly installed. Fedora appears to break up Perl modules into small packages that need to be installed for the build to succeed. Signed-off-by: Bas Mevissen <abuse@basmevissen.nl> (cherry picked from commit f68c9474acf9a65b5a9538db8e45c173462487e3)
-rw-r--r--include/prereq-build.mk13
1 files changed, 12 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 54ed0e6f90..cfcc6b3654 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -68,11 +68,22 @@ $(eval $(call TestHostCommand,perl-data-dumper, \
Please install the Perl Data::Dumper module, \
perl -MData::Dumper -e 1))
+$(eval $(call TestHostCommand,perl-findbin, \
+ Please install the Perl FindBin module, \
+ perl -MFindBin -e 1))
+
+$(eval $(call TestHostCommand,perl-file-copy, \
+ Please install the Perl File::Copy module, \
+ perl -MFile::Copy -e 1))
+
+$(eval $(call TestHostCommand,perl-file-compare, \
+ Please install the Perl File::Compare module, \
+ perl -MFile::Compare -e 1))
+
$(eval $(call TestHostCommand,perl-thread-queue, \
Please install the Perl Thread::Queue module, \
perl -MThread::Queue -e 1))
-
$(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
gtar --version 2>&1 | grep GNU, \
gnutar --version 2>&1 | grep GNU, \