summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2023-05-09 21:39:58 +0200
committerPaul Spooren <mail@aparcar.org>2023-05-11 13:15:02 +0200
commit491b784141da22d01819196e748e955cf07fd56a (patch)
tree763754e210938f442740524f3b274f9bf96bdef2
parent6a12ecbd6dd61bb9da35d75735e1280313659a20 (diff)
downloadopenwrt-491b784141da22d01819196e748e955cf07fd56a.tar.gz
openwrt-491b784141da22d01819196e748e955cf07fd56a.tar.bz2
openwrt-491b784141da22d01819196e748e955cf07fd56a.zip
build: generate index.json
The index.json file lies next to Packages index files and contains a json dict with the package architecture and a dict of package names and versions. This can be used for downstream project to know what packages in which versions are available. Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 218ce40cd738f3373438aab82467807a8707fb9c)
-rw-r--r--package/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index 209be34674..4b8df7f484 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -92,6 +92,10 @@ $(curdir)/index: FORCE
$(call ERROR_MESSAGE,WARNING: Applying padding in $$d/Packages to workaround usign SHA-512 bug!); \
{ echo ""; echo ""; } >> Packages;; \
esac; \
+ echo -n '{"architecture": "$(ARCH_PACKAGES)", "packages":{' > index.json; \
+ sed -n -e 's/^Package: \(.*\)$$/"\1":/p' -e 's/^Version: \(.*\)$$/"\1",/p' Packages | tr '\n' ' ' >> index.json; \
+ echo '}}' >> index.json; \
+ sed -i 's/, }}/}}/' index.json; \
gzip -9nc Packages > Packages.gz; \
); done
ifdef CONFIG_SIGNED_PACKAGES