summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2023-03-12 16:56:41 +0100
committerPaul Spooren <mail@aparcar.org>2023-04-09 14:28:16 +0200
commitbc99ce5b22963c22661b3e549c3cdc86bf52756c (patch)
tree34289cd04cfcb015b0d069459a4515feddff3fb0
parentcbe73ea33d027dbb4b2cf1eca947ae746119e7d2 (diff)
downloadopenwrt-bc99ce5b22963c22661b3e549c3cdc86bf52756c.tar.gz
openwrt-bc99ce5b22963c22661b3e549c3cdc86bf52756c.tar.bz2
openwrt-bc99ce5b22963c22661b3e549c3cdc86bf52756c.zip
imagebuilder: allow to specific ROOTFS_PARTSIZE
Setting this options modifies the rootfs size of created images. When installing a large number of packages it may become necessary to increase the size to have enough storage. This option is only useful for supported devices, i.e. with an attached SD Card or installed on a hard drive. Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 7b7edd25a571568438c886529d3443054e02f55f)
-rw-r--r--target/imagebuilder/files/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index aeae98aacd..eadb0ebe85 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -47,6 +47,7 @@ Building images:
make image EXTRA_IMAGE_NAME="<string>" # Add this to the output image filename (sanitized)
make image DISABLED_SERVICES="<svc1> [<svc2> [<svc3> ..]]" # Which services in /etc/init.d/ should be disabled
make image ADD_LOCAL_KEY=1 # store locally generated signing key in built images
+ make image ROOTFS_PARTSIZE="<size>" # override the default rootfs partition size in MegaBytes
Print manifest:
List "all" packages which get installed into the image.
@@ -243,7 +244,8 @@ image:
$(if $(FILES),USER_FILES="$(FILES)") \
$(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)") \
$(if $(BIN_DIR),BIN_DIR="$(BIN_DIR)") \
- $(if $(DISABLED_SERVICES),DISABLED_SERVICES="$(DISABLED_SERVICES)"))
+ $(if $(DISABLED_SERVICES),DISABLED_SERVICES="$(DISABLED_SERVICES)") \
+ $(if $(ROOTFS_PARTSIZE),CONFIG_TARGET_ROOTFS_PARTSIZE="$(ROOTFS_PARTSIZE)"))
manifest: FORCE
$(MAKE) -s _check_profile