summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRani Hod <rani.hod@gmail.com>2023-09-30 22:22:13 +0300
committerRafał Miłecki <rafal@milecki.pl>2023-10-26 13:43:33 +0200
commitc5cb4287b836038b90d699c0e1a36ef617f603f2 (patch)
tree78ed7f8e5c436eb8b6e2ea7d769be98be36970b9
parent66c2715a562684c30b4027ba16e23c295580f44d (diff)
downloadopenwrt-c5cb4287b836038b90d699c0e1a36ef617f603f2.tar.gz
openwrt-c5cb4287b836038b90d699c0e1a36ef617f603f2.tar.bz2
openwrt-c5cb4287b836038b90d699c0e1a36ef617f603f2.zip
bcm53xx: build a single device per profile
So far every build of a single bcm53xx Target Profile (it means: when NOT using CONFIG_TARGET_MULTI_PROFILE) resulted in all target devices images being built. Now it only builds the one matching selected profile. Fixes: #13572 Suggested-by: Jonas Gorski <jonas.gorski@gmail.com> Signed-off-by: Rani Hod <rani.hod@gmail.com> [rmilecki: update commit subject + body & move PROFILES line] Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit 802a5f5cb4a7b42d25e82b787d7ab1323a20183f)
-rw-r--r--target/linux/bcm53xx/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 312e5d62b7..5143d3a4af 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -121,6 +121,7 @@ USB2_PACKAGES += kmod-usb-ledtrig-usbport
USB3_PACKAGES := $(USB2_PACKAGES) kmod-usb3 kmod-phy-bcm-ns-usb3
define Device/Default
+ PROFILES = Generic $$(DEVICE_NAME)
# .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
# extract the full dtb name based on the device info
DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(subst _,-,$(1)).dtb)))