summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2023-09-19 00:10:03 +0200
committerArne Zachlod <arne@nerdkeller.org>2023-09-27 17:23:27 +0200
commitddc361f1a62e53e492df31ded4453662c57434b1 (patch)
treec4401c8877ec6535df9409eca7de6f244ba69fa9
parent9431f3625bc6831e775c1bb820a3a3caacb26f03 (diff)
downloadopenwrt-ddc361f1a62e53e492df31ded4453662c57434b1.tar.gz
openwrt-ddc361f1a62e53e492df31ded4453662c57434b1.tar.bz2
openwrt-ddc361f1a62e53e492df31ded4453662c57434b1.zip
tools: assign PKG_CPE_ID
The PKG_CPE_ID links to NIST CPE version 2.2. Assign PKG_CPE_ID to all remaining tools which have a CPE ID. Not every tool has CPE id. Related: https://github.com/openwrt/packages/issues/8534 Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
-rw-r--r--tools/bison/Makefile1
-rw-r--r--tools/gmp/Makefile1
-rw-r--r--tools/mtd-utils/Makefile1
-rw-r--r--tools/sed/Makefile1
-rw-r--r--tools/zip/Makefile1
5 files changed, 5 insertions, 0 deletions
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
index 8f3043fcb8..f07a128b01 100644
--- a/tools/bison/Makefile
+++ b/tools/bison/Makefile
@@ -12,6 +12,7 @@ PKG_VERSION:=3.7.4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
PKG_HASH:=a3b5813f48a11e540ef26f46e4d288c0c25c7907d9879ae50e430ec49f63c010
+PKG_CPE_ID:=cpe:/a:gnu:bison
HOST_BUILD_PARALLEL:=1
diff --git a/tools/gmp/Makefile b/tools/gmp/Makefile
index 967cf6817b..48f556f4fc 100644
--- a/tools/gmp/Makefile
+++ b/tools/gmp/Makefile
@@ -12,6 +12,7 @@ PKG_VERSION:=6.2.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/gmp/
PKG_HASH:=fd4829912cddd12f84181c3451cc752be224643e87fac497b69edddadc49b4f2
+PKG_CPE_ID:=cpe:/a:gmplib:gmp
HOST_FIXUP:=autoreconf
diff --git a/tools/mtd-utils/Makefile b/tools/mtd-utils/Makefile
index 7eebcfb827..5268dd03a3 100644
--- a/tools/mtd-utils/Makefile
+++ b/tools/mtd-utils/Makefile
@@ -13,6 +13,7 @@ PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/mtd-utils/
PKG_HASH:=8ad4c5f34716d40646aa28724a2f5616d325a6f119254f914e26976f1f76e9d6
+PKG_CPE_ID:=cpe:/a:mtd-utils_project:mtd-utils
PKG_FIXUP:=autoreconf
diff --git a/tools/sed/Makefile b/tools/sed/Makefile
index 4218ac2d59..58f70c4ad9 100644
--- a/tools/sed/Makefile
+++ b/tools/sed/Makefile
@@ -12,6 +12,7 @@ PKG_VERSION:=4.8
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
PKG_HASH:=f79b0cfea71b37a8eeec8490db6c5f7ae7719c35587f21edb0617f370eeff633
+PKG_CPE_ID:=cpe:/a:gnu:sed
export SED:=
HOST_BUILD_PARALLEL:=1
diff --git a/tools/zip/Makefile b/tools/zip/Makefile
index 7dd81a1b8b..4490cf9213 100644
--- a/tools/zip/Makefile
+++ b/tools/zip/Makefile
@@ -17,6 +17,7 @@ PKG_HASH:=f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369
PKG_LICENSE:=BSD-4-Clause
PKG_LICENSE_FILES:=LICENSE
+PKG_CPE_ID:=cpe:/a:zip_project:zip
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)/zip$(PKG_REV)
HOST_BUILD_PARALLEL:=1