summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-11-08 13:31:12 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-11-08 22:01:43 +0100
commit469577886551d9d941c5144295e4b80238d16d41 (patch)
treee742ec8e356a0d8c8e289c53fa20cfa46191652e
parent2bdec1190381cfefb5ef37c411ab598573cc8ae4 (diff)
downloadopenwrt-469577886551d9d941c5144295e4b80238d16d41.tar.gz
openwrt-469577886551d9d941c5144295e4b80238d16d41.tar.bz2
openwrt-469577886551d9d941c5144295e4b80238d16d41.zip
gemini: usb-fotg210: enable OTG support
The usb-fotg210 does not currently select CONFIG_USB_FOTG210_UDC which enable OTG support, but it was previously selected directly in the target kernel config so lets enable it to keep the functionality identical. Signed-off-by: Robert Marko <robimarko@gmail.com>
-rw-r--r--target/linux/gemini/modules.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/gemini/modules.mk b/target/linux/gemini/modules.mk
index 29a3266f51..30f3884e10 100644
--- a/target/linux/gemini/modules.mk
+++ b/target/linux/gemini/modules.mk
@@ -1,8 +1,10 @@
define KernelPackage/usb-fotg210
TITLE:=Support for FOTG210 USB host and device controllers
DEPENDS:=@USB_SUPPORT @TARGET_gemini
- KCONFIG:=CONFIG_USB_FOTG210 \
- CONFIG_USB_FOTG210_HCD=y
+ KCONFIG:= \
+ CONFIG_USB_FOTG210 \
+ CONFIG_USB_FOTG210_HCD=y \
+ CONFIG_USB_FOTG210_UDC=y
FILES:=$(LINUX_DIR)/drivers/usb/fotg210/fotg210.ko
AUTOLOAD:=$(call AutoLoad,50,1)
$(call AddDepends/usb)