summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-18 03:15:31 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-18 16:13:10 +0100
commit29a4a17f55e1c6ef8c50370766160a92233813b5 (patch)
tree65d8e60e417ba057f52253819bb9280b935fed9e
parentc71e13a81a3aad967e2480eb43377bd44d13936b (diff)
downloadopenwrt-29a4a17f55e1c6ef8c50370766160a92233813b5.tar.gz
openwrt-29a4a17f55e1c6ef8c50370766160a92233813b5.tar.bz2
openwrt-29a4a17f55e1c6ef8c50370766160a92233813b5.zip
sdk: do not strip static libraries
Do not strip static libraries shipped with the SDK in order to preserve the archive index. If we strip the index of the shipped libraries, host programs will fail to link these libraries with errors like: libssl.a: error adding symbols: Archive has no index; run ranlib to add one The error was found while investigating a Python host build failure within the SDK environment. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--target/sdk/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index e9599c3c69..496f025393 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -92,7 +92,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
find \
$(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/lib \
$(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/usr/lib \
- -type f -name \*.so\* -or -name \*.a; \
+ -type f -name \*.so\*; \
) | xargs strip 2>/dev/null >/dev/null
mkdir -p $(SDK_BUILD_DIR)/target/linux