summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMirko Vogt <mirko-openwrt@nanl.de>2017-01-18 14:36:45 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-19 12:34:04 +0100
commitc76da7757323d268b394cbda2e4748eedbb2496a (patch)
tree6334148f8a4dfe42020fadc614124b6bacfcadd6
parent29a4a17f55e1c6ef8c50370766160a92233813b5 (diff)
downloadopenwrt-c76da7757323d268b394cbda2e4748eedbb2496a.tar.gz
openwrt-c76da7757323d268b394cbda2e4748eedbb2496a.tar.bz2
openwrt-c76da7757323d268b394cbda2e4748eedbb2496a.zip
git-kernel: $(SUBDIR) should always be $(LINUX_VERSION)
Before SUBDIR was set to $(PATCHVER) which may or may not include the minor version number of the linux kernel version. Usually it doesn't. So the git-clone'd linux kernel was packed without the minor version number taken into account, which broke further processing, as it expected the extracted dir being named linux-$(LINUX_VERSION) (=with minor version) rather than linux-$(PATCHVER) (=without minor version). Changing SUBDIR to $(LINUX_VERSION) creates consistent behaviour here. Signed-off-by: Mirko Vogt <mirko-openwrt@nanl.de>
-rw-r--r--include/kernel-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 2bf47b17e4..32da94babc 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -60,7 +60,7 @@ define Download/git-kernel
PROTO:=git
VERSION:=$(CONFIG_KERNEL_GIT_BRANCH)
FILE:=$(LINUX_SOURCE)
- SUBDIR:=linux-$(KERNEL_PATCHVER)
+ SUBDIR:=linux-$(LINUX_VERSION)
OPTS:=$(KERNEL_GIT_OPTS)
endef