summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-07-20 10:40:43 +0200
committerJo-Philipp Wich <jo@mein.io>2018-07-20 15:37:46 +0200
commit21c317a892071e8cc8fc268df18130540d3db358 (patch)
treecf0f7190e3b8c125936800220517cdd1e5bca989
parentaee5c53a8d68c9894cc2062db18ca7375af85b4a (diff)
downloadopenwrt-21c317a892071e8cc8fc268df18130540d3db358.tar.gz
openwrt-21c317a892071e8cc8fc268df18130540d3db358.tar.bz2
openwrt-21c317a892071e8cc8fc268df18130540d3db358.zip
build: fix compile error when a package includes itself in PROVIDES
Signed-off-by: Felix Fietkau <nbd@nbd.name> (cherry picked from commit 7c306ae640feb4d42b352175de27b034bd917938)
-rw-r--r--include/package-ipkg.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index d9b6f77cc4..a9cd51e80f 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -196,7 +196,7 @@ $(_endef)
fi; \
done; $(Package/$(1)/extra_provides) \
) | sort -u > $(PKG_INFO_DIR)/$(1).provides
- $(if $(PROVIDES),@for pkg in $(PROVIDES); do cp $(PKG_INFO_DIR)/$(1).provides $(PKG_INFO_DIR)/$$$$pkg.provides; done)
+ $(if $(PROVIDES),@for pkg in $(filter-out $(1),$(PROVIDES)); do cp $(PKG_INFO_DIR)/$(1).provides $(PKG_INFO_DIR)/$$$$pkg.provides; done)
$(CheckDependencies)
$(RSTRIP) $$(IDIR_$(1))