summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-01-05 10:43:55 +0100
committerJo-Philipp Wich <jo@mein.io>2018-08-04 13:47:02 +0200
commitbcf91e578c0fff183c34a52364ef44d78ee74d51 (patch)
treea35c4be3ded6effd92991fcea3863af78b7c1126
parentb7e3f10e801998781cf123b9c81c305004f03439 (diff)
downloadopenwrt-bcf91e578c0fff183c34a52364ef44d78ee74d51.tar.gz
openwrt-bcf91e578c0fff183c34a52364ef44d78ee74d51.tar.bz2
openwrt-bcf91e578c0fff183c34a52364ef44d78ee74d51.zip
downloads.mk: introduce name-agnostic PROJECT_GIT variable
Introduce a name-agnostic PROJECT_GIT variable poiting to https://git.openwrt.org/ and declare LEDE_GIT and OPENWRT_GIT as aliases to it. After some transition time we can drop this alias variables. Signed-off-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit 4700544e4068cb72932148ac1ecd294ca1388671)
-rw-r--r--include/download.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/include/download.mk b/include/download.mk
index 0a25641738..2ba8a7bdf4 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -6,8 +6,10 @@
# See /LICENSE for more information.
#
-OPENWRT_GIT = http://git.openwrt.org
-LEDE_GIT = https://git.lede-project.org
+PROJECT_GIT = https://git.openwrt.org
+
+OPENWRT_GIT = $(PROJECT_GIT)
+LEDE_GIT = $(PROJECT_GIT)
ifdef PKG_SOURCE_VERSION
PKG_VERSION ?= $(if $(PKG_SOURCE_DATE),$(PKG_SOURCE_DATE)-)$(call version_abbrev,$(PKG_SOURCE_VERSION))