summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-08-01 09:11:17 +0200
committerJo-Philipp Wich <jo@mein.io>2018-08-04 13:44:10 +0200
commitd93ef3c8c8a22768ae33ad7c7ca603d12a5c88f8 (patch)
tree419a3fe32d459196b4995eebc16dd2b3d3dec84b
parente5b7404f25b808427a336454c88c45cc09e3d498 (diff)
downloadopenwrt-d93ef3c8c8a22768ae33ad7c7ca603d12a5c88f8.tar.gz
openwrt-d93ef3c8c8a22768ae33ad7c7ca603d12a5c88f8.tar.bz2
openwrt-d93ef3c8c8a22768ae33ad7c7ca603d12a5c88f8.zip
sdk: bundle usbip userspace sources
Bundle the usbip utility sources shipped with the Linux kernel tree in order to allow the usbip packages from the package feed to build within the OpenWrt SDK. Signed-off-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit d0e0b7049f88774e67c3d5ad6b573f7070e5f900)
-rw-r--r--target/sdk/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 54a14d352b..80deedbbd6 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -83,6 +83,10 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
$(SDK_DIRS) $(KERNEL_FILES) | \
$(TAR) -xf - -C $(SDK_BUILD_DIR)
+ # Copy usbip sources, this is required for the usbip userspace packages to be buildable by the SDK.
+ $(TAR) -cf - -C $(TOPDIR) $(KDIR_BASE)/tools/usb/usbip/ | \
+ $(TAR) -xf - -C $(SDK_BUILD_DIR)
+
(cd $(SDK_BUILD_DIR); find $(STAGING_SUBDIR_HOST)/bin $(STAGING_SUBDIR_HOST)/usr/bin \
$(STAGING_SUBDIR_TOOLCHAIN)/bin $(STAGING_SUBDIR_TOOLCHAIN)/*/bin $(STAGING_SUBDIR_TOOLCHAIN)/libexec \
-type f | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST))