summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-07-14 15:44:47 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-07-14 15:48:14 +0200
commita7b2764879dbcf7c6b1d5463158c4e51ca993974 (patch)
tree68092bf204eb09c4f5ad7bd9680ae366f78c95d4
parentbc7abe8729f3ff611dec597ae2831aefdc748567 (diff)
downloadopenwrt-a7b2764879dbcf7c6b1d5463158c4e51ca993974.tar.gz
openwrt-a7b2764879dbcf7c6b1d5463158c4e51ca993974.tar.bz2
openwrt-a7b2764879dbcf7c6b1d5463158c4e51ca993974.zip
include/prereq-build.mk: explicitly check for -f flag when using busybox time
On Debian, busybox does have a time applet, but it does not support the -f flag. Catch this in prereq check to give users to proper error message. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> (cherry picked from commit b123921a92a957f08abb186e041aa38aa9328f3e)
-rw-r--r--include/prereq-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 72875aef4e..edd63e9ee6 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -138,10 +138,10 @@ $(eval $(call SetupHostCommand,bzip2,Please install 'bzip2', \
$(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
wget --version | grep GNU))
-$(eval $(call SetupHostCommand,time,Please install GNU 'time' or BusyBox 'time', \
+$(eval $(call SetupHostCommand,time,Please install GNU 'time' or BusyBox 'time' that supports -f, \
gtime --version 2>&1 | grep GNU, \
time --version 2>&1 | grep GNU, \
- busybox time 2>&1 | grep BusyBox))
+ busybox time 2>&1 | grep -- '-f FMT'))
$(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
perl --version | grep "perl.*v5"))