summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-06-19 10:06:50 +0200
committerFelix Fietkau <nbd@nbd.name>2018-07-03 11:20:37 +0200
commit5505ab5c947b10a2ce3997f2747420ea9ea103ca (patch)
tree4ba07535888e89781c31e00b802ac84e3fb0ec8e
parentab7cabd09df542cf3558725573c2ef2cf1c7cdff (diff)
downloadopenwrt-5505ab5c947b10a2ce3997f2747420ea9ea103ca.tar.gz
openwrt-5505ab5c947b10a2ce3997f2747420ea9ea103ca.tar.bz2
openwrt-5505ab5c947b10a2ce3997f2747420ea9ea103ca.zip
ramips: limit dictionary size for lzma compression
In some cases, recent builds fail to boot from flash with at least some MT7621 based devices. The error message is: "LZMA ERROR 1 - must RESET board to recover" Booting the same kernel via TFTP works for some reason. Through testing I figured out that limiting the LZMA dictionary size seems to prevent these errors Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 8ab8aa3a6c..cd77ffe411 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -31,7 +31,7 @@ loadaddr-$(CONFIG_TARGET_ramips_mt7621) := 0x80001000
KERNEL_LOADADDR := $(loadaddr-y)
-KERNEL_DTB = kernel-bin | patch-dtb | lzma
+KERNEL_DTB = kernel-bin | patch-dtb | lzma -d21
define Device/Default
PROFILES = Default $$(DTS)
KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)