summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2018-12-30 20:46:06 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-01-01 18:54:14 +0100
commit8a9b0b95df7d96bc51d6e4731264add11f72925d (patch)
tree8e60727070b02265b2ca60cd6511303e549b5340
parentafcdf099b7cc505acf9497a3dbccf4e6bdc29c27 (diff)
downloadopenwrt-8a9b0b95df7d96bc51d6e4731264add11f72925d.tar.gz
openwrt-8a9b0b95df7d96bc51d6e4731264add11f72925d.tar.bz2
openwrt-8a9b0b95df7d96bc51d6e4731264add11f72925d.zip
apm821xx: switch MX60(W)'s recovery images to multi-image method
In the past, the MX60(W)'s recovery images always had problems with the size restriction and never really worked without manual intervention. This patch reworks the initramfs, which allows the device to ease up on the impossible tight kernel size requirements for the initramfs image. This new initramfs can be loaded through the MX60(W) U-boot in the following way: => setenv bootargs console=ttyS0,$baudrate => tftpboot $meraki_loadaddr meraki_mx60-initramfs-kernel.bin [...] Load address: 0x800000 Loading: ################################################ [...] done [...] => bootm $fileaddr \## Booting kernel from Legacy Image at 00800000 ... ... For more information and the latest flashing guide: please visit the OpenWrt Wiki Page for the MX60(W): <https://openwrt.org/toh/meraki/mx60#flashing> Signed-off-by: Chris Blake <chrisrblake93@gmail.com> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> (cherry picked from commit 36c19c9f0be23ad327085aa762e95de638e19b4a)
-rw-r--r--target/linux/apm821xx/image/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 1e94a40918..7f33c660e6 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -102,13 +102,10 @@ define Device/meraki_mx60
# otherwise the final image will fail to boot. This is set within the
# MX60 kernel header definition which is found at
# ./tools/firmware-utils/src/mkmerakifw.c, line 103~
- KERNEL_SIZE := 2984k
+ KERNEL_SIZE := 4031k
IMAGE_SIZE := 1021m
KERNEL := kernel-bin | gzip | uImage gzip | MerakiAdd-dtb | MerakiNAND
- KERNEL_INITRAMFS := copy-file $(KDIR)/vmlinux | gzip | uImage gzip | \
- check-size $$(KERNEL_SIZE) | \
- MerakiAdd-dtb | pad-to 2047k | MerakiAdd-initramfs | \
- MerakiNAND
+ KERNEL_INITRAMFS := kernel-bin | gzip | dtb | MuImage-initramfs gzip
IMAGE/sysupgrade.tar := sysupgrade-tar | append-metadata
UBINIZE_OPTS := -E 5
SUPPORTED_DEVICES += mx60