summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-09-09 13:07:58 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-09-11 10:01:24 +0200
commitc5ed9f43446995d283fdd67acb24bbc2b3c47198 (patch)
treeb01c83fd43576ce770d23e924cbaf9f580603fe3
parent556f86bbfd9cadf70ddb03755d70eeb8e5670260 (diff)
downloadopenwrt-c5ed9f43446995d283fdd67acb24bbc2b3c47198.tar.gz
openwrt-c5ed9f43446995d283fdd67acb24bbc2b3c47198.tar.bz2
openwrt-c5ed9f43446995d283fdd67acb24bbc2b3c47198.zip
kernel: bump 4.14 to 4.14.142
Refreshed all patches. Remove upstreamed: - 0032-usb-host-fotg2-restart-hcd-after-port-reset.patch Compile-tested on: cns3xxx, imx6 Runtime-tested on: cns3xxx, imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/gemini/patches-4.14/0028-usb-host-fotg2-add-device-tree-probing.patch4
-rw-r--r--target/linux/gemini/patches-4.14/0029-usb-host-fotg2-add-silicon-clock-handling.patch6
-rw-r--r--target/linux/gemini/patches-4.14/0030-usb-host-fotg2-add-Gemini-specific-handling.patch4
-rw-r--r--target/linux/gemini/patches-4.14/0032-usb-host-fotg2-restart-hcd-after-port-reset.patch26
5 files changed, 9 insertions, 35 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 87814cd3ae..009feeacfe 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,10 +3,10 @@
LINUX_RELEASE?=1
LINUX_VERSION-4.9 = .191
-LINUX_VERSION-4.14 = .141
+LINUX_VERSION-4.14 = .142
LINUX_KERNEL_HASH-4.9.191 = ded4b87406deb67112b25a2283e8b5c89c2b47e2de14a97acda57f74cd38b7bc
-LINUX_KERNEL_HASH-4.14.141 = 0bb9f0812326ec4554de1bea02628840e03b6664b5abfd9d8510049e43203a17
+LINUX_KERNEL_HASH-4.14.142 = e67ba535991170a8383be68203af7d9b4262474ceeff2f9afedeac6043b590f3
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/gemini/patches-4.14/0028-usb-host-fotg2-add-device-tree-probing.patch b/target/linux/gemini/patches-4.14/0028-usb-host-fotg2-add-device-tree-probing.patch
index 862cb64909..01a704830f 100644
--- a/target/linux/gemini/patches-4.14/0028-usb-host-fotg2-add-device-tree-probing.patch
+++ b/target/linux/gemini/patches-4.14/0028-usb-host-fotg2-add-device-tree-probing.patch
@@ -24,7 +24,7 @@ ChangeLog v2->v3:
#include <linux/device.h>
#include <linux/dmapool.h>
#include <linux/kernel.h>
-@@ -5600,6 +5601,15 @@ static int fotg210_hcd_probe(struct plat
+@@ -5604,6 +5605,15 @@ static int fotg210_hcd_probe(struct plat
if (usb_disabled())
return -ENODEV;
@@ -40,7 +40,7 @@ ChangeLog v2->v3:
pdev->dev.power.power_state = PMSG_ON;
res = platform_get_resource(pdev, IORESOURCE_IRQ, 0);
-@@ -5676,9 +5686,18 @@ static int fotg210_hcd_remove(struct pla
+@@ -5680,9 +5690,18 @@ static int fotg210_hcd_remove(struct pla
return 0;
}
diff --git a/target/linux/gemini/patches-4.14/0029-usb-host-fotg2-add-silicon-clock-handling.patch b/target/linux/gemini/patches-4.14/0029-usb-host-fotg2-add-silicon-clock-handling.patch
index 4a1faf938e..5ecd9297e5 100644
--- a/target/linux/gemini/patches-4.14/0029-usb-host-fotg2-add-silicon-clock-handling.patch
+++ b/target/linux/gemini/patches-4.14/0029-usb-host-fotg2-add-silicon-clock-handling.patch
@@ -26,7 +26,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
#include <asm/byteorder.h>
#include <asm/irq.h>
-@@ -5635,7 +5636,7 @@ static int fotg210_hcd_probe(struct plat
+@@ -5639,7 +5640,7 @@ static int fotg210_hcd_probe(struct plat
hcd->regs = devm_ioremap_resource(&pdev->dev, res);
if (IS_ERR(hcd->regs)) {
retval = PTR_ERR(hcd->regs);
@@ -35,7 +35,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
}
hcd->rsrc_start = res->start;
-@@ -5645,22 +5646,35 @@ static int fotg210_hcd_probe(struct plat
+@@ -5649,22 +5650,35 @@ static int fotg210_hcd_probe(struct plat
fotg210->caps = hcd->regs;
@@ -74,7 +74,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
usb_put_hcd(hcd);
fail_create_hcd:
dev_err(dev, "init %s fail, %d\n", dev_name(dev), retval);
-@@ -5676,6 +5690,10 @@ static int fotg210_hcd_remove(struct pla
+@@ -5680,6 +5694,10 @@ static int fotg210_hcd_remove(struct pla
{
struct device *dev = &pdev->dev;
struct usb_hcd *hcd = dev_get_drvdata(dev);
diff --git a/target/linux/gemini/patches-4.14/0030-usb-host-fotg2-add-Gemini-specific-handling.patch b/target/linux/gemini/patches-4.14/0030-usb-host-fotg2-add-Gemini-specific-handling.patch
index 2e781e403d..0125e816d6 100644
--- a/target/linux/gemini/patches-4.14/0030-usb-host-fotg2-add-Gemini-specific-handling.patch
+++ b/target/linux/gemini/patches-4.14/0030-usb-host-fotg2-add-Gemini-specific-handling.patch
@@ -43,7 +43,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
#include <asm/byteorder.h>
#include <asm/irq.h>
-@@ -5583,6 +5587,72 @@ static void fotg210_init(struct fotg210_
+@@ -5587,6 +5591,72 @@ static void fotg210_init(struct fotg210_
iowrite32(value, &fotg210->regs->otgcsr);
}
@@ -116,7 +116,7 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
/**
* fotg210_hcd_probe - initialize faraday FOTG210 HCDs
*
-@@ -5662,6 +5732,12 @@ static int fotg210_hcd_probe(struct plat
+@@ -5666,6 +5736,12 @@ static int fotg210_hcd_probe(struct plat
fotg210_init(fotg210);
diff --git a/target/linux/gemini/patches-4.14/0032-usb-host-fotg2-restart-hcd-after-port-reset.patch b/target/linux/gemini/patches-4.14/0032-usb-host-fotg2-restart-hcd-after-port-reset.patch
deleted file mode 100644
index 80b2fc4104..0000000000
--- a/target/linux/gemini/patches-4.14/0032-usb-host-fotg2-restart-hcd-after-port-reset.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 731a2896e11b4e6a8d252e6c14edb1b09dbfcd46 Mon Sep 17 00:00:00 2001
-From: Hans Ulli Kroll <ulli.kroll@googlemail.com>
-Date: Sat, 14 Apr 2018 18:49:57 +0200
-Subject: [PATCH 1/2] usb: host: fotg2: restart hcd after port reset
-
-on Gemini SoC FOTG2 stalls after port reset
-rerstart the hcd.
-
-Signed-off-by: Hans Ulli Kroll <ulli.kroll@googlemail.com>
----
- drivers/usb/host/fotg210-hcd.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
---- a/drivers/usb/host/fotg210-hcd.c
-+++ b/drivers/usb/host/fotg210-hcd.c
-@@ -1658,6 +1658,10 @@ static int fotg210_hub_control(struct us
- /* see what we found out */
- temp = check_reset_complete(fotg210, wIndex, status_reg,
- fotg210_readl(fotg210, status_reg));
-+
-+ /* restart schedule */
-+ fotg210->command |= CMD_RUN;
-+ fotg210_writel(fotg210, fotg210->command, &fotg210->regs->command);
- }
-
- if (!(temp & (PORT_RESUME|PORT_RESET))) {