summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKamil Wcislo <kamil.wcislo@lpnplant.io>2018-07-05 21:40:19 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2019-11-23 13:36:28 +0100
commit15ce616c2de797259cc125f1ece5f2358ea4bd5a (patch)
treee751f2f2cf9af6f835c5327ed5645a615c5a261b
parent436dbf12aa7381bd6db1b03b36be5a73df386eb4 (diff)
downloadopenwrt-15ce616c2de797259cc125f1ece5f2358ea4bd5a.tar.gz
openwrt-15ce616c2de797259cc125f1ece5f2358ea4bd5a.tar.bz2
openwrt-15ce616c2de797259cc125f1ece5f2358ea4bd5a.zip
build: add PKG_SOURCE_URL_FILE support
It seems that there is a missing PKG_SOURCE_URL_FILE support. This little fix adds the support for packages to change the name of the downloaded file. Sometimes it is desirable to change the downloaded archive file name, like for mitigating name conflicts for different packages (some files on the server could be named like, e.g. 2018-01-01.tar.gz) or for the cases that there is no name for the file in the URL (e.g. http://someserver.com/download). Signed-off-by: Kamil Wcislo <kamil.wcislo@lpnplant.io> Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> (cherry picked from commit 09c428ec6bca27bdb31e2f6fef85b07787cead30)
-rw-r--r--include/download.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/download.mk b/include/download.mk
index 09794e155e..14d68bf8f5 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -289,6 +289,7 @@ endef
define Download/default
FILE:=$(PKG_SOURCE)
URL:=$(PKG_SOURCE_URL)
+ URL_FILE:=$(PKG_SOURCE_URL_FILE)
SUBDIR:=$(PKG_SOURCE_SUBDIR)
PROTO:=$(PKG_SOURCE_PROTO)
$(if $(PKG_SOURCE_MIRROR),MIRROR:=$(filter 1,$(PKG_MIRROR)))