summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-12-29 18:19:08 -1000
committerPaul Spooren <mail@aparcar.org>2020-12-31 09:33:07 -1000
commit2c37993c8a6f64b736f3ad37c1ac20046d0d1e1b (patch)
treed6961d1cf1273823a22ff89d56f686e313873b54
parent79b1fa170288115d1929c55713dc840a133bddd9 (diff)
downloadopenwrt-2c37993c8a6f64b736f3ad37c1ac20046d0d1e1b.tar.gz
openwrt-2c37993c8a6f64b736f3ad37c1ac20046d0d1e1b.tar.bz2
openwrt-2c37993c8a6f64b736f3ad37c1ac20046d0d1e1b.zip
build/prereq: merge ifndef IB block together
Multiple prereq checks are only required within the build system but not for the ImageBuilder. These checks are excluded by using ifndef IB. This commit merges the three ifndef IB blocks together. Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit cc9d5b5a488d3a43068f621a1ef184f06e43bede)
-rw-r--r--include/prereq-build.mk6
1 files changed, 1 insertions, 5 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 7504d43a74..1384f27e82 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -38,9 +38,7 @@ $(eval $(call TestHostCommand,working-gcc, \
it appears to be broken, \
echo 'int main(int argc, char **argv) { return 0; }' | \
gcc -x c -o $(TMP_DIR)/a.out -))
-endif
-ifndef IB
$(eval $(call SetupHostCommand,g++, \
Please install the GNU C++ Compiler (g++) 4.8 or later, \
$(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
@@ -53,14 +51,12 @@ $(eval $(call TestHostCommand,working-g++, \
echo 'int main(int argc, char **argv) { return 0; }' | \
g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
$(TMP_DIR)/a.out))
-endif
-ifndef IB
$(eval $(call TestHostCommand,ncurses, \
Please install ncurses. (Missing libncurses.so or ncurses.h), \
echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
-endif
+endif # IB
ifeq ($(HOST_OS),Linux)
zlib_link_flags := -Wl,-Bstatic -lz -Wl,-Bdynamic