summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-04-14 11:14:47 -1000
committerPaul Spooren <mail@aparcar.org>2020-12-31 09:31:54 -1000
commit58138df2d56789f0b3da3fe0592d9d1288803bcb (patch)
tree56032579b77ccd8253cb78648d6b7c9fe66d8d29
parent42e478eb0dbfce71ba21d2a6ed7297ec6db8cc19 (diff)
downloadopenwrt-58138df2d56789f0b3da3fe0592d9d1288803bcb.tar.gz
openwrt-58138df2d56789f0b3da3fe0592d9d1288803bcb.tar.bz2
openwrt-58138df2d56789f0b3da3fe0592d9d1288803bcb.zip
build, imagebuilder: Do not require libncurses-dev
The buildroot and SDK both require `libncurses-dev` to be installed on the system, however the ImageBuilder uses precompiled binaries. This patch changes the prerequirements checks to skip the `libncurses-dev` part if running as ImageBuilder. Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 4a1a58a3e2d2360950ff23a05f1f55b779174d6a)
-rw-r--r--include/prereq-build.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 501739968c..622db96ee3 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -51,10 +51,12 @@ $(eval $(call TestHostCommand,working-g++, \
g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
$(TMP_DIR)/a.out))
+ifndef IB
$(eval $(call TestHostCommand,ncurses, \
Please install ncurses. (Missing libncurses.so or ncurses.h), \
echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
+endif
ifeq ($(HOST_OS),Linux)
zlib_link_flags := -Wl,-Bstatic -lz -Wl,-Bdynamic