summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Roederer <devel-sven@geroedel.de>2020-09-27 23:07:38 +0200
committerPaul Spooren <mail@aparcar.org>2020-12-31 09:32:33 -1000
commit79b1fa170288115d1929c55713dc840a133bddd9 (patch)
treed9e80270c217cacce580b94afaac7c7a7b29c16d
parent58138df2d56789f0b3da3fe0592d9d1288803bcb (diff)
downloadopenwrt-79b1fa170288115d1929c55713dc840a133bddd9.tar.gz
openwrt-79b1fa170288115d1929c55713dc840a133bddd9.tar.bz2
openwrt-79b1fa170288115d1929c55713dc840a133bddd9.zip
build, imagebuilder: Do not require compilers
The buildroot and SDK both require the compilers (gcc, g++) to be installed on the host system, however the ImageBuilder uses precompiled binaries. This patch changes the prerequirements checks to skip the checking for the compilers if running as ImageBuilder. A similar change has been made for libncurses-dev in 4a1a58a3e2d2. Signed-off-by: Sven Roederer <devel-sven@geroedel.de> Acked-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit ae12a747cae3df16d84b7dc92f39427948d4e8e2)
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 622db96ee3..7504d43a74 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -26,6 +26,7 @@ $(eval $(call TestHostCommand,proper-umask, \
Please build with umask 022 - other values produce broken packages, \
umask | grep -xE 0?0[012][012]))
+ifndef IB
$(eval $(call SetupHostCommand,gcc, \
Please install the GNU C Compiler (gcc) 4.8 or later, \
$(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
@@ -37,7 +38,9 @@ $(eval $(call TestHostCommand,working-gcc, \
it appears to be broken, \
echo 'int main(int argc, char **argv) { return 0; }' | \
gcc -x c -o $(TMP_DIR)/a.out -))
+endif
+ifndef IB
$(eval $(call SetupHostCommand,g++, \
Please install the GNU C++ Compiler (g++) 4.8 or later, \
$(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
@@ -50,6 +53,7 @@ $(eval $(call TestHostCommand,working-g++, \
echo 'int main(int argc, char **argv) { return 0; }' | \
g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
$(TMP_DIR)/a.out))
+endif
ifndef IB
$(eval $(call TestHostCommand,ncurses, \