summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlberto Bursi <bobafetthotmail@gmail.com>2020-11-17 08:58:40 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-12-01 13:31:18 +0100
commitc420f7767855e51d88f82307da0aa28af3d44f64 (patch)
treea519f2b9b9cc4a0bcd3d2fb1dd582cc36135f148
parent0ce0d687de9e7b386912ba8883470ce33d4c8008 (diff)
downloadopenwrt-c420f7767855e51d88f82307da0aa28af3d44f64.tar.gz
openwrt-c420f7767855e51d88f82307da0aa28af3d44f64.tar.bz2
openwrt-c420f7767855e51d88f82307da0aa28af3d44f64.zip
wireguard-tools: fix category/description in menuconfig
wireguard-tools is trying to import the menuconfig section from the wireguard package, but since it's not anymore in the same makefile this seems to fail and wireguard-tools ends up in "extra packages" category instead with other odds and ends. Same for the description, it's trying to import it from the wireguard package but it fails so it only shows the line written in this makefile. remove the broken imports and add manually the entries and description they were supposed to load Fixes: ea980fb9c6de ("wireguard: bump to 20191226") Signed-off-by: Alberto Bursi <bobafetthotmail@gmail.com> [fix trailing whitespaces, add Fixes] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit a4d52522c7fbc47a04215b8f04a2e1f7cf7aafea)
-rw-r--r--package/network/utils/wireguard-tools/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/package/network/utils/wireguard-tools/Makefile b/package/network/utils/wireguard-tools/Makefile
index 2f6d307094..ff0207d6da 100644
--- a/package/network/utils/wireguard-tools/Makefile
+++ b/package/network/utils/wireguard-tools/Makefile
@@ -31,13 +31,22 @@ MAKE_PATH:=src
MAKE_VARS += PLATFORM=linux
define Package/wireguard-tools
- $(call Package/wireguard/Default)
+ SECTION:=net
+ CATEGORY:=Network
+ SUBMENU:=VPN
+ URL:=https://www.wireguard.com
+ MAINTAINER:=Jason A. Donenfeld <Jason@zx2c4.com>
TITLE:=WireGuard userspace control program (wg)
DEPENDS:=+libmnl +ip
endef
define Package/wireguard-tools/description
- $(call Package/wireguard/Default/description)
+ WireGuard is a novel VPN that runs inside the Linux Kernel and utilizes
+ state-of-the-art cryptography. It aims to be faster, simpler, leaner, and
+ more useful than IPSec, while avoiding the massive headache. It intends to
+ be considerably more performant than OpenVPN. WireGuard is designed as a
+ general purpose VPN for running on embedded interfaces and super computers
+ alike, fit for many different circumstances. It uses UDP.
This package provides the userspace control program for WireGuard,
`wg(8)`, a netifd protocol helper, and a re-resolve watchdog script.