summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-11-21 15:59:50 +0100
committerPetr Štetiar <ynezz@true.cz>2020-12-05 20:50:19 +0100
commitd83040313390f56c22ff020f0f20da8f05e98e35 (patch)
treed16bb8d7fb9000d8e9523adc61614edc8ffbfc81
parent8c2bb1d9b6b71be31ff79c1783b42b457d305cd0 (diff)
downloadopenwrt-d83040313390f56c22ff020f0f20da8f05e98e35.tar.gz
openwrt-d83040313390f56c22ff020f0f20da8f05e98e35.tar.bz2
openwrt-d83040313390f56c22ff020f0f20da8f05e98e35.zip
toolchain: kernel-headers: kernel Git tree mirror hash
Allow setting of mirror hash for Git kernel tree. Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 796d51834c5be85771d26e433fd509cd3bef72e3)
-rw-r--r--config/Config-devel.in5
-rw-r--r--toolchain/kernel-headers/Makefile1
2 files changed, 6 insertions, 0 deletions
diff --git a/config/Config-devel.in b/config/Config-devel.in
index fd7c3ead1e..1c514f86d4 100644
--- a/config/Config-devel.in
+++ b/config/Config-devel.in
@@ -100,6 +100,11 @@ menuconfig DEVEL
It can be a git hash or a branch name.
If unused, the clone's repository HEAD will be checked-out.
+ config KERNEL_GIT_MIRROR_HASH
+ string "Enter hash of Git kernel tree source checkout tarball" if DEVEL
+ depends on (KERNEL_GIT_CLONE_URI != "")
+ default ""
+
config BUILD_LOG
bool "Enable log files during build process" if DEVEL
help
diff --git a/toolchain/kernel-headers/Makefile b/toolchain/kernel-headers/Makefile
index 1da1946a14..6931881493 100644
--- a/toolchain/kernel-headers/Makefile
+++ b/toolchain/kernel-headers/Makefile
@@ -21,6 +21,7 @@ ifneq ($(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI)),)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI))
PKG_SOURCE_VERSION:=$(call qstrip,$(CONFIG_KERNEL_GIT_REF))
+ PKG_MIRROR_HASH:=$(call qstrip,$(CONFIG_KERNEL_GIT_MIRROR_HASH))
ifdef CHECK
include $(INCLUDE_DIR)/kernel-version.mk
PKG_VERSION:=$(LINUX_VERSION)