summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2021-02-04 17:20:28 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2021-02-05 09:30:47 +0100
commit4465b44fc1a93ef4f480d22b405caae980f1b6f5 (patch)
treebf34abcee230e5cf112eed204ffca77c3449a993
parent4b9ade65eca26feeeabedf2344f84671d4685150 (diff)
downloadopenwrt-4465b44fc1a93ef4f480d22b405caae980f1b6f5.tar.gz
openwrt-4465b44fc1a93ef4f480d22b405caae980f1b6f5.tar.bz2
openwrt-4465b44fc1a93ef4f480d22b405caae980f1b6f5.zip
kernel: bump 4.14 to 4.14.219
Refreshed all patches. Compile-tested on: ar71xx, cns3xxx, imx6, x86_64 Runtime-tested on: ar71xx, cns3xxx, imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch2
-rw-r--r--target/linux/ath79/patches-4.14/910-unaligned_access_hacks.patch2
3 files changed, 4 insertions, 4 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 90a67f5c65..885bbcdc40 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-4.14 = .218
+LINUX_VERSION-4.14 = .219
-LINUX_KERNEL_HASH-4.14.218 = e3fe86a15e03dcb8d4d74facd6f902eb994e3a0a7a9f189fad2a1cc7d8655950
+LINUX_KERNEL_HASH-4.14.219 = 75eecaa731c091fcf3bc2ec914b01d299a447d78041cb66a11a2ab169eb801dd
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch b/target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch
index 2f622dc505..b847a3e1d5 100644
--- a/target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch
+++ b/target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch
@@ -757,7 +757,7 @@
EXPORT_SYMBOL(xfrm_parse_spi);
--- a/net/ipv4/tcp_input.c
+++ b/net/ipv4/tcp_input.c
-@@ -3879,14 +3879,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3881,14 +3881,16 @@ static bool tcp_parse_aligned_timestamp(
{
const __be32 *ptr = (const __be32 *)(th + 1);
diff --git a/target/linux/ath79/patches-4.14/910-unaligned_access_hacks.patch b/target/linux/ath79/patches-4.14/910-unaligned_access_hacks.patch
index 9222bee694..afa5023043 100644
--- a/target/linux/ath79/patches-4.14/910-unaligned_access_hacks.patch
+++ b/target/linux/ath79/patches-4.14/910-unaligned_access_hacks.patch
@@ -737,7 +737,7 @@
EXPORT_SYMBOL(xfrm_parse_spi);
--- a/net/ipv4/tcp_input.c
+++ b/net/ipv4/tcp_input.c
-@@ -3879,14 +3879,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3881,14 +3881,16 @@ static bool tcp_parse_aligned_timestamp(
{
const __be32 *ptr = (const __be32 *)(th + 1);