summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Gordziejewski <openwrt@flicksfix.com>2022-04-08 00:29:20 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-05-17 21:14:23 +0200
commit7152bc84f4adc750112bc426244e93cba8d2a922 (patch)
treebc54438bb6bb8f221da033c912457569bf7fceb8
parentd627ea510c36c2d2049bc062d236aea2c23bd636 (diff)
downloadopenwrt-7152bc84f4adc750112bc426244e93cba8d2a922.tar.gz
openwrt-7152bc84f4adc750112bc426244e93cba8d2a922.tar.bz2
openwrt-7152bc84f4adc750112bc426244e93cba8d2a922.zip
ramips: add support for TP-Link RE650 v2
TP-Link RE650 v2 is largely similar to v1 that is already supported by OpenWrt. Notable differences is differnt SPI Flash - 8 MB instead of 16 MB (from cFeon instead of Winbond) and a different configuration of PCIE connections to wifi chips. Otherwise it's largely the same product as v1 Hardware specification: - SoC 880 MHz - MediaTek MT7621AT - 128 MB of DDR3 RAM - 8 MB - cFeon QH64A-104HIP - 4T4R 2.4 GHz - MediaTek MT7615E - 4T4R 5 GHz - MediaTek MT7615E - 1x 1 Gbps Ethernet - MT7621AT integrated - 7x LEDs (Power, 2G, 5G, WPS(x2), Lan(x2)) - 4x buttons (Reset, Power, WPS, LED) - UART pinout - GND, RX, TX, labeled in the middle of the PCB, requires soldering because they're not through holes. Serial console @ 57600,8n1 Flash instructions: Upload openwrt-ramips-mt7621-tplink_re650-v2-squashfs-factory.bin from the RE650 web interface. TFTP recovery to stock firmware: I didn't try recovering back to the stock firmware, however, if there is such process for other RExxx devices, it seems like it could be similar here. Signed-off-by: Marcin Gordziejewski <openwrt@flicksfix.com> (cherry picked from commit 39799974a372fb4333d21f077c670b8a56b9d696)
-rw-r--r--target/linux/ramips/dts/mt7621_tplink_re650-v2.dts195
-rw-r--r--target/linux/ramips/image/mt7621.mk11
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/01_leds3
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/02_network1
4 files changed, 209 insertions, 1 deletions
diff --git a/target/linux/ramips/dts/mt7621_tplink_re650-v2.dts b/target/linux/ramips/dts/mt7621_tplink_re650-v2.dts
new file mode 100644
index 0000000000..aa65b68f06
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_tplink_re650-v2.dts
@@ -0,0 +1,195 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "tplink,re650-v2", "mediatek,mt7621-soc";
+ model = "TP-Link RE650 v2";
+
+ aliases {
+ label-mac-device = &gmac0;
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ wps {
+ label = "wps";
+ gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+
+ power {
+ label = "power";
+ gpios = <&gpio 25 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ linux,code = <KEY_POWER>;
+ };
+
+ led {
+ label = "led";
+ gpios = <&gpio 30 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ linux,code = <KEY_LIGHTS_TOGGLE>;
+ };
+
+ reset {
+ label = "reset";
+ gpios = <&gpio 31 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power: power {
+ label = "blue:power";
+ gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
+ };
+
+ wifi2g {
+ label = "blue:wifi2g";
+ gpios = <&gpio 23 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ wifi5g {
+ label = "blue:wifi5g";
+ gpios = <&gpio 24 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ wps_red {
+ label = "red:wps";
+ gpios = <&gpio 26 GPIO_ACTIVE_HIGH>;
+ };
+
+ wps_blue {
+ label = "blue:wps";
+ gpios = <&gpio 27 GPIO_ACTIVE_HIGH>;
+ };
+
+ eth_act {
+ label = "green:eth_act";
+ gpios = <&gpio 28 GPIO_ACTIVE_LOW>;
+ };
+
+ eth_link {
+ label = "green:eth_link";
+ gpios = <&gpio 29 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x20000>;
+ read-only;
+ };
+
+ partition@20000 {
+ compatible = "tplink,firmware";
+ label = "firmware";
+ reg = <0x20000 0x7a0000>;
+ };
+
+ config: partition@7c0000 {
+ label = "config";
+ reg = <0x7c0000 0x2d440>;
+ read-only;
+ };
+
+ radio: partition@7f0000 {
+ label = "radio";
+ reg = <0x7f0000 0x10000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "rgmii2", "wdt";
+ function = "gpio";
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&radio 0x0>;
+ nvmem-cells = <&macaddr_config_10008>;
+ nvmem-cell-names = "mac-address";
+ mac-address-increment = <1>;
+ ieee80211-freq-limit = <2400000 2500000>;
+ };
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&radio 0x8000>;
+ nvmem-cells = <&macaddr_config_10008>;
+ nvmem-cell-names = "mac-address";
+ mac-address-increment = <2>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
+
+&ethernet {
+ pinctrl-0 = <&mdio_pins>, <&rgmii1_pins>;
+};
+
+&gmac0 {
+ nvmem-cells = <&macaddr_config_10008>;
+ nvmem-cell-names = "mac-address";
+};
+
+&switch0 {
+ ports {
+ port@0 {
+ status = "okay";
+ label = "lan";
+ };
+ };
+};
+
+&config {
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_config_10008: macaddr@10008 {
+ reg = <0x10008 0x6>;
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index bd0d6ad654..369ff520a3 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1633,6 +1633,17 @@ define Device/tplink_re650-v1
endef
TARGET_DEVICES += tplink_re650-v1
+define Device/tplink_re650-v2
+ $(Device/dsa-migration)
+ $(Device/tplink-safeloader)
+ DEVICE_MODEL := RE650
+ DEVICE_VARIANT := v2
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware
+ TPLINK_BOARD_ID := RE650-V2
+ IMAGE_SIZE := 7994k
+endef
+TARGET_DEVICES += tplink_re650-v2
+
define Device/tplink_tl-wpa8631p-v3
$(Device/dsa-migration)
$(Device/tplink-safeloader)
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
index fc6e7ede3c..2cb8fdb557 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
@@ -120,7 +120,8 @@ tplink,re350-v1)
ucidef_set_led_netdev "eth_link" "LAN link" "green:eth_link" "lan" "link"
;;
tplink,re500-v1|\
-tplink,re650-v1)
+tplink,re650-v1|\
+tplink,re650-v2)
ucidef_set_led_netdev "eth_act" "LAN act" "green:eth_act" "lan" "tx rx"
ucidef_set_led_netdev "eth_link" "LAN link" "green:eth_link" "lan" "link"
;;
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index 8e89ccacba..75842f4cbc 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -17,6 +17,7 @@ ramips_setup_interfaces()
tplink,re350-v1|\
tplink,re500-v1|\
tplink,re650-v1|\
+ tplink,re650-v2|\
ubnt,unifi-6-lite|\
ubnt,unifi-nanohd)
ucidef_set_interface_lan "lan"