summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Audia <therealgraysky@proton.me>2022-05-30 08:45:46 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2022-06-07 22:28:59 +0200
commit0ca93670693bc63045b181505d9ff69c4bde5750 (patch)
tree6faa65ab18b1ee4d10b35e8c86b2474a23fa7286
parent49f8a75031c8fb2efc4824166da75f1473cdab6b (diff)
downloadopenwrt-0ca93670693bc63045b181505d9ff69c4bde5750.tar.gz
openwrt-0ca93670693bc63045b181505d9ff69c4bde5750.tar.bz2
openwrt-0ca93670693bc63045b181505d9ff69c4bde5750.zip
kernel: bump 5.10 to 5.10.119
Delete the crypto-lib-blake2s kmod package, as BLAKE2s is now built-in. Patches automatically rebased. Build system: x86_64 Build-tested: ipq806x/R7800, x86/64 Signed-off-by: John Audia <therealgraysky@proton.me> (cherry picked from commit cd634afe6cb6565eb6865931c8d73d97cab3600a)
-rw-r--r--include/kernel-5.104
-rw-r--r--package/kernel/linux/modules/crypto.mk23
-rw-r--r--package/kernel/linux/modules/netsupport.mk1
-rw-r--r--target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch4
-rw-r--r--target/linux/generic/config-5.101
-rw-r--r--target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch4
-rw-r--r--target/linux/generic/pending-5.10/205-backtrace_module_info.patch4
-rw-r--r--target/linux/realtek/patches-5.10/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch2
8 files changed, 9 insertions, 34 deletions
diff --git a/include/kernel-5.10 b/include/kernel-5.10
index c05a5d8425..f12a386aa5 100644
--- a/include/kernel-5.10
+++ b/include/kernel-5.10
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.10 = .118
-LINUX_KERNEL_HASH-5.10.118 = c5e020f187a195ab0924fe7e71b8ab8fb92936ab47bc9d15e78daabddefe0b4b
+LINUX_VERSION-5.10 = .119
+LINUX_KERNEL_HASH-5.10.119 = 3e353e55a2b7074c905c7c517c6dae83eae440f98a12ffd471dc4df1d5172511
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 4097957277..445b2e353b 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -446,29 +446,6 @@ endef
$(eval $(call KernelPackage,crypto-kpp))
-
-define KernelPackage/crypto-lib-blake2s
- TITLE:=BLAKE2s hash function library
- KCONFIG:=CONFIG_CRYPTO_LIB_BLAKE2S
- HIDDEN:=1
- FILES:= \
- $(LINUX_DIR)/lib/crypto/libblake2s.ko \
- $(LINUX_DIR)/lib/crypto/libblake2s-generic.ko
- $(call AddDepends/crypto,+PACKAGE_kmod-crypto-hash:kmod-crypto-hash)
-endef
-
-define KernelPackage/crypto-lib-blake2s/config
- imply PACKAGE_kmod-crypto-hash
-endef
-
-define KernelPackage/crypto-lib-blake2s/x86/64
- KCONFIG+=CONFIG_CRYPTO_BLAKE2S_X86
- FILES+=$(LINUX_DIR)/arch/x86/crypto/blake2s-x86_64.ko
-endef
-
-$(eval $(call KernelPackage,crypto-lib-blake2s))
-
-
define KernelPackage/crypto-lib-chacha20
TITLE:=ChaCha library interface
KCONFIG:=CONFIG_CRYPTO_LIB_CHACHA
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index fd9051586a..689efc3722 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1324,7 +1324,6 @@ define KernelPackage/wireguard
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=WireGuard secure network tunnel
DEPENDS:= \
- +kmod-crypto-lib-blake2s \
+kmod-crypto-lib-chacha20poly1305 \
+kmod-crypto-lib-curve25519 \
+kmod-udptunnel4 \
diff --git a/target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch b/target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch
index f2f48d6543..f66f4fc4b6 100644
--- a/target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch
+++ b/target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch
@@ -656,8 +656,8 @@
#include <linux/types.h>
+#include <linux/in6.h>
- u32 secure_ipv4_port_ephemeral(__be32 saddr, __be32 daddr, __be16 dport);
- u32 secure_ipv6_port_ephemeral(const __be32 *saddr, const __be32 *daddr,
+ u64 secure_ipv4_port_ephemeral(__be32 saddr, __be32 daddr, __be16 dport);
+ u64 secure_ipv6_port_ephemeral(const __be32 *saddr, const __be32 *daddr,
--- a/include/uapi/linux/in.h
+++ b/include/uapi/linux/in.h
@@ -88,7 +88,7 @@ enum {
diff --git a/target/linux/generic/config-5.10 b/target/linux/generic/config-5.10
index f8f332bd7b..e557379d24 100644
--- a/target/linux/generic/config-5.10
+++ b/target/linux/generic/config-5.10
@@ -1144,7 +1144,6 @@ CONFIG_CRYPTO_KPP=y
CONFIG_CRYPTO_KPP2=y
CONFIG_CRYPTO_LIB_AES=y
CONFIG_CRYPTO_LIB_ARC4=y
-# CONFIG_CRYPTO_LIB_BLAKE2S is not set
# CONFIG_CRYPTO_LIB_CHACHA is not set
# CONFIG_CRYPTO_LIB_CHACHA20POLY1305 is not set
# CONFIG_CRYPTO_LIB_CURVE25519 is not set
diff --git a/target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch b/target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch
index a7668acfad..dfba811f31 100644
--- a/target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch
+++ b/target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch
@@ -4,7 +4,7 @@ from backports.
--- a/lib/crypto/Kconfig
+++ b/lib/crypto/Kconfig
-@@ -6,7 +6,7 @@ config CRYPTO_LIB_AES
+@@ -4,7 +4,7 @@ config CRYPTO_LIB_AES
tristate
config CRYPTO_LIB_ARC4
@@ -12,4 +12,4 @@ from backports.
+ tristate "ARC4 cipher library"
config CRYPTO_ARCH_HAVE_LIB_BLAKE2S
- tristate
+ bool
diff --git a/target/linux/generic/pending-5.10/205-backtrace_module_info.patch b/target/linux/generic/pending-5.10/205-backtrace_module_info.patch
index f46877f254..f1f35c9923 100644
--- a/target/linux/generic/pending-5.10/205-backtrace_module_info.patch
+++ b/target/linux/generic/pending-5.10/205-backtrace_module_info.patch
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/lib/vsprintf.c
+++ b/lib/vsprintf.c
-@@ -983,8 +983,10 @@ char *symbol_string(char *buf, char *end
+@@ -985,8 +985,10 @@ char *symbol_string(char *buf, char *end
struct printf_spec spec, const char *fmt)
{
unsigned long value;
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
#endif
if (fmt[1] == 'R')
-@@ -1001,8 +1003,14 @@ char *symbol_string(char *buf, char *end
+@@ -1003,8 +1005,14 @@ char *symbol_string(char *buf, char *end
return string_nocheck(buf, end, sym, spec);
#else
diff --git a/target/linux/realtek/patches-5.10/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch b/target/linux/realtek/patches-5.10/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch
index cc5ee92466..845441b425 100644
--- a/target/linux/realtek/patches-5.10/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch
+++ b/target/linux/realtek/patches-5.10/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch
@@ -32,7 +32,7 @@ Signed-off-by: Guenter Roeck <linux@roeck-us.net>
--- a/MAINTAINERS
+++ b/MAINTAINERS
-@@ -14814,6 +14814,13 @@ S: Maintained
+@@ -14816,6 +14816,13 @@ S: Maintained
F: include/sound/rt*.h
F: sound/soc/codecs/rt*