summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Audia <therealgraysky@proton.me>2022-06-06 07:05:18 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2022-06-07 22:28:59 +0200
commitff889898d29603878f82b53eb9860e54ed0ebb43 (patch)
tree6ff89f0a07dc9d3115505751b00741b58eb5f82a
parent0ca93670693bc63045b181505d9ff69c4bde5750 (diff)
downloadopenwrt-ff889898d29603878f82b53eb9860e54ed0ebb43.tar.gz
openwrt-ff889898d29603878f82b53eb9860e54ed0ebb43.tar.bz2
openwrt-ff889898d29603878f82b53eb9860e54ed0ebb43.zip
kernel: bump 5.10 to 5.10.120
All patches automatically rebased. Build system: x86_64 Build-tested: ipq806x/R7800, x86/64 Signed-off-by: John Audia <therealgraysky@proton.me> (cherry picked from commit f800f8d6fc4f21ed87454aa657ebbf376dc3b6cf)
-rw-r--r--include/kernel-5.104
-rw-r--r--target/linux/ath25/patches-5.10/700-swconfig_mvswitch.patch4
-rw-r--r--target/linux/generic/backport-5.10/610-v5.13-10-netfilter-nftables-update-table-flags-from-the-commi.patch4
-rw-r--r--target/linux/generic/hack-5.10/251-kconfig.patch2
-rw-r--r--target/linux/generic/hack-5.10/253-ksmbd-config.patch2
-rw-r--r--target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch2
-rw-r--r--target/linux/generic/pending-5.10/530-jffs2_make_lzma_available.patch2
-rw-r--r--target/linux/ipq40xx/patches-5.10/707-net-phy-Add-Qualcom-QCA807x-driver.patch2
-rw-r--r--target/linux/realtek/patches-5.10/705-add-rtl-phy.patch2
9 files changed, 12 insertions, 12 deletions
diff --git a/include/kernel-5.10 b/include/kernel-5.10
index f12a386aa5..168fc255e5 100644
--- a/include/kernel-5.10
+++ b/include/kernel-5.10
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.10 = .119
-LINUX_KERNEL_HASH-5.10.119 = 3e353e55a2b7074c905c7c517c6dae83eae440f98a12ffd471dc4df1d5172511
+LINUX_VERSION-5.10 = .120
+LINUX_KERNEL_HASH-5.10.120 = 5b7a756004158ece2f5e41795ba523ec201743a736e34ce41cbe09177f7d0e8b
diff --git a/target/linux/ath25/patches-5.10/700-swconfig_mvswitch.patch b/target/linux/ath25/patches-5.10/700-swconfig_mvswitch.patch
index 32f332189b..79a4d1c1a0 100644
--- a/target/linux/ath25/patches-5.10/700-swconfig_mvswitch.patch
+++ b/target/linux/ath25/patches-5.10/700-swconfig_mvswitch.patch
@@ -13,8 +13,8 @@
select SWCONFIG
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -29,6 +29,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
+@@ -31,6 +31,7 @@ ar8xxx-y += ar8216.o
+ ar8xxx-y += ar8327.o
obj-$(CONFIG_SWCONFIG_B53) += b53/
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
diff --git a/target/linux/generic/backport-5.10/610-v5.13-10-netfilter-nftables-update-table-flags-from-the-commi.patch b/target/linux/generic/backport-5.10/610-v5.13-10-netfilter-nftables-update-table-flags-from-the-commi.patch
index fa6e0c4173..55c04ba4fd 100644
--- a/target/linux/generic/backport-5.10/610-v5.13-10-netfilter-nftables-update-table-flags-from-the-commi.patch
+++ b/target/linux/generic/backport-5.10/610-v5.13-10-netfilter-nftables-update-table-flags-from-the-commi.patch
@@ -70,7 +70,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
nft_trans_table_update(trans) = true;
list_add_tail(&trans->list, &ctx->net->nft.commit_list);
return 0;
-@@ -7908,11 +7912,10 @@ static int nf_tables_commit(struct net *
+@@ -7918,11 +7922,10 @@ static int nf_tables_commit(struct net *
switch (trans->msg_type) {
case NFT_MSG_NEWTABLE:
if (nft_trans_table_update(trans)) {
@@ -86,7 +86,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
} else {
nft_clear(net, trans->ctx.table);
}
-@@ -8125,11 +8128,9 @@ static int __nf_tables_abort(struct net
+@@ -8135,11 +8138,9 @@ static int __nf_tables_abort(struct net
switch (trans->msg_type) {
case NFT_MSG_NEWTABLE:
if (nft_trans_table_update(trans)) {
diff --git a/target/linux/generic/hack-5.10/251-kconfig.patch b/target/linux/generic/hack-5.10/251-kconfig.patch
index 34a63eaa7c..4ada399fbf 100644
--- a/target/linux/generic/hack-5.10/251-kconfig.patch
+++ b/target/linux/generic/hack-5.10/251-kconfig.patch
@@ -92,7 +92,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
bool
--- a/lib/Kconfig
+++ b/lib/Kconfig
-@@ -418,16 +418,16 @@ config BCH_CONST_T
+@@ -420,16 +420,16 @@ config BCH_CONST_T
# Textsearch support is select'ed if needed
#
config TEXTSEARCH
diff --git a/target/linux/generic/hack-5.10/253-ksmbd-config.patch b/target/linux/generic/hack-5.10/253-ksmbd-config.patch
index c2b2a96b9c..adce3f5f15 100644
--- a/target/linux/generic/hack-5.10/253-ksmbd-config.patch
+++ b/target/linux/generic/hack-5.10/253-ksmbd-config.patch
@@ -11,7 +11,7 @@
that can be interpreted by the ASN.1 stream decoder and used to
--- a/lib/Kconfig
+++ b/lib/Kconfig
-@@ -589,7 +589,7 @@ config LIBFDT
+@@ -591,7 +591,7 @@ config LIBFDT
bool
config OID_REGISTRY
diff --git a/target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch b/target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch
index dfba811f31..4ffd8cfa37 100644
--- a/target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch
+++ b/target/linux/generic/hack-5.10/261-lib-arc4-unhide.patch
@@ -4,7 +4,7 @@ from backports.
--- a/lib/crypto/Kconfig
+++ b/lib/crypto/Kconfig
-@@ -4,7 +4,7 @@ config CRYPTO_LIB_AES
+@@ -6,7 +6,7 @@ config CRYPTO_LIB_AES
tristate
config CRYPTO_LIB_ARC4
diff --git a/target/linux/generic/pending-5.10/530-jffs2_make_lzma_available.patch b/target/linux/generic/pending-5.10/530-jffs2_make_lzma_available.patch
index 20483a391d..d30d3b7560 100644
--- a/target/linux/generic/pending-5.10/530-jffs2_make_lzma_available.patch
+++ b/target/linux/generic/pending-5.10/530-jffs2_make_lzma_available.patch
@@ -1087,7 +1087,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
#define JFFS2_NODE_ACCURATE 0x2000
--- a/lib/Kconfig
+++ b/lib/Kconfig
-@@ -315,6 +315,12 @@ config ZSTD_DECOMPRESS
+@@ -317,6 +317,12 @@ config ZSTD_DECOMPRESS
source "lib/xz/Kconfig"
diff --git a/target/linux/ipq40xx/patches-5.10/707-net-phy-Add-Qualcom-QCA807x-driver.patch b/target/linux/ipq40xx/patches-5.10/707-net-phy-Add-Qualcom-QCA807x-driver.patch
index ba441022f3..12b21a803c 100644
--- a/target/linux/ipq40xx/patches-5.10/707-net-phy-Add-Qualcom-QCA807x-driver.patch
+++ b/target/linux/ipq40xx/patches-5.10/707-net-phy-Add-Qualcom-QCA807x-driver.patch
@@ -40,7 +40,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
help
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -86,6 +86,7 @@ obj-$(CONFIG_MICROSEMI_PHY) += mscc/
+@@ -88,6 +88,7 @@ obj-$(CONFIG_MICROSEMI_PHY) += mscc/
obj-$(CONFIG_NATIONAL_PHY) += national.o
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
diff --git a/target/linux/realtek/patches-5.10/705-add-rtl-phy.patch b/target/linux/realtek/patches-5.10/705-add-rtl-phy.patch
index 4f907e1d4b..e88c26b348 100644
--- a/target/linux/realtek/patches-5.10/705-add-rtl-phy.patch
+++ b/target/linux/realtek/patches-5.10/705-add-rtl-phy.patch
@@ -15,7 +15,7 @@
help
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -87,6 +87,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
+@@ -89,6 +89,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o