summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-12-09 15:45:04 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2023-04-02 22:07:28 +0200
commit0636d6b925ad25aa155b411a54921b03c97a9349 (patch)
tree6bd61b16562205014d500c657c18577e6fb00a26
parent70d2e8b4db0c5c9f1a2d40827928bef8083b19d6 (diff)
downloadopenwrt-0636d6b925ad25aa155b411a54921b03c97a9349.tar.gz
openwrt-0636d6b925ad25aa155b411a54921b03c97a9349.tar.bz2
openwrt-0636d6b925ad25aa155b411a54921b03c97a9349.zip
ath79: use lzma-loader for Senao initramfs images
Some vendors of Senao boards have put a bootloader that cannot handle both large gzip or large lzma files. There is no disadvantage by doing this for all of them. Signed-off-by: Michael Pratt <mcpratt@pm.me> (cherry picked from commit 8342c092a03caedbf160d4ac3982c6a9be91261f)
-rw-r--r--target/linux/ath79/image/common-senao.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ath79/image/common-senao.mk b/target/linux/ath79/image/common-senao.mk
index dda7da6776..a0cb729ee2 100644
--- a/target/linux/ath79/image/common-senao.mk
+++ b/target/linux/ath79/image/common-senao.mk
@@ -30,6 +30,7 @@ endef
define Device/senao_loader_okli
$(Device/loader-okli-uimage)
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x73714f4b
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel | uImage none
LOADER_KERNEL_MAGIC := 0x73714f4b
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | \