summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArınç ÜNAL <arinc.unal@arinc9.com>2023-08-10 15:23:09 +0300
committerRafał Miłecki <rafal@milecki.pl>2023-10-26 11:16:24 +0200
commit0e23d247190c1f2d96b29ab9729190d9008d1516 (patch)
treee419c611398cbb2079c537d7955b2d158041885d
parent2adf034d2263e1a2f35ff7f8fa491f6898465aff (diff)
downloadopenwrt-0e23d247190c1f2d96b29ab9729190d9008d1516.tar.gz
openwrt-0e23d247190c1f2d96b29ab9729190d9008d1516.tar.bz2
openwrt-0e23d247190c1f2d96b29ab9729190d9008d1516.zip
bcm53xx: add support for ASUS RT-AC3100
ASUS RT-AC3100 is ASUS RT-AC88U without the external switch. OpenWrt forum users effortless and ktmakwana have confirmed that there are revisions with either 4366b1 or 4366c0 wireless chips. Therefore, include firmware for 4366b1 along with 4366c0. This way, all hardware revisions of the router will be supported by having brcmfmac use the firmware file for the wireless chip it detects. Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com> (cherry picked from commit 2214bab3503981fe6168746acd13044a9d5e89e7)
-rw-r--r--target/linux/bcm53xx/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index dcfa3a239e..7b53967504 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -143,6 +143,14 @@ define Device/asus
IMAGE/trx := append-ubi | trx-nand | asus-trx
endef
+define Device/asus_rt-ac3100
+ $(call Device/asus)
+ DEVICE_MODEL := RT-AC3100
+ DEVICE_PACKAGES := $(BRCMFMAC_4366B1) $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+ ASUS_PRODUCTID := RT-AC3100
+endef
+TARGET_DEVICES += asus_rt-ac3100
+
define Device/asus_rt-ac56u
$(call Device/asus)
DEVICE_MODEL := RT-AC56U