summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRani Hod <rani.hod@gmail.com>2023-09-30 22:22:13 +0300
committerRafał Miłecki <rafal@milecki.pl>2023-10-26 11:16:24 +0200
commit20a046eee652ac2a57ea2de6ff938084cfdb8dd4 (patch)
treec2c56e1fa5159bb80ab94ed777100285527d3969
parent0e23d247190c1f2d96b29ab9729190d9008d1516 (diff)
downloadopenwrt-20a046eee652ac2a57ea2de6ff938084cfdb8dd4.tar.gz
openwrt-20a046eee652ac2a57ea2de6ff938084cfdb8dd4.tar.bz2
openwrt-20a046eee652ac2a57ea2de6ff938084cfdb8dd4.zip
bcm53xx: build a single device per profile
So far every build of a single bcm53xx Target Profile (it means: when NOT using CONFIG_TARGET_MULTI_PROFILE) resulted in all target devices images being built. Now it only builds the one matching selected profile. Fixes: #13572 Suggested-by: Jonas Gorski <jonas.gorski@gmail.com> Signed-off-by: Rani Hod <rani.hod@gmail.com> [rmilecki: update commit subject + body & move PROFILES line] Signed-off-by: Rafał Miłecki <rafal@milecki.pl> (cherry picked from commit 802a5f5cb4a7b42d25e82b787d7ab1323a20183f)
-rw-r--r--target/linux/bcm53xx/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 7b53967504..ae83ad920c 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -121,6 +121,7 @@ USB2_PACKAGES += kmod-usb-ledtrig-usbport
USB3_PACKAGES := $(USB2_PACKAGES) kmod-usb3 kmod-phy-bcm-ns-usb3
define Device/Default
+ PROFILES = Generic $$(DEVICE_NAME)
# .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
# extract the full dtb name based on the device info
DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(subst _,-,$(1)).dtb)))