summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-11-08 16:46:12 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-11-09 16:18:58 +0100
commit64907f3c34e2c1b59a6f8afe7cab5da1befea54f (patch)
tree7d87dfa678936d031f70559a46219b7742d97147
parent6e77f51b3aefa6bc6a9abbc5e911c172850c4d54 (diff)
downloadopenwrt-64907f3c34e2c1b59a6f8afe7cab5da1befea54f.tar.gz
openwrt-64907f3c34e2c1b59a6f8afe7cab5da1befea54f.tar.bz2
openwrt-64907f3c34e2c1b59a6f8afe7cab5da1befea54f.zip
hostapd: fix broke noscan option for mesh
noscan option for mesh was broken and actually never applied. This is caused by a typo where ssid->noscan value is check instead of conf->noscan resulting in the logic swapped and broken. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com> (cherry picked from commit 1b5ea2e199fcf391f88afd0322de449459399be4) [ rework for openwrt-22.03 ]
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/patches/301-mesh-noscan.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index a06f6a0523..f831304dcd 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -5,7 +5,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=$(AUTORELEASE).2
+PKG_RELEASE:=$(AUTORELEASE).3
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/patches/301-mesh-noscan.patch b/package/network/services/hostapd/patches/301-mesh-noscan.patch
index e682efb543..b27ffc4493 100644
--- a/package/network/services/hostapd/patches/301-mesh-noscan.patch
+++ b/package/network/services/hostapd/patches/301-mesh-noscan.patch
@@ -24,8 +24,8 @@
frequency);
goto out_free;
}
-+ if (ssid->noscan)
-+ conf->noscan = 1;
++ if (conf->noscan)
++ ssid->noscan = 1;
if (ssid->mesh_basic_rates == NULL) {
/*