summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Karlsson <erik.karlsson@genexis.eu>2023-09-06 12:33:17 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-09-24 13:22:34 +0200
commit2d812f0b72bdb2f2d4b70a4a9c91821ac42df489 (patch)
tree8391a7c9d70b0571082ebd8578e9a1ff48fe46dd
parent4c2f44c859b13501c05b595e4f836f7ca7d90ae4 (diff)
downloadopenwrt-2d812f0b72bdb2f2d4b70a4a9c91821ac42df489.tar.gz
openwrt-2d812f0b72bdb2f2d4b70a4a9c91821ac42df489.tar.bz2
openwrt-2d812f0b72bdb2f2d4b70a4a9c91821ac42df489.zip
procd: create /dev/fd symlink
This is needed for ksh/bash style process substitution such as <(command) and >(command) which was introduced in ash as of busybox version 1.34.0 to work. Signed-off-by: Erik Karlsson <erik.karlsson@genexis.eu> (cherry picked from commit fdce970dbb47a6f91b08bdac21a098e77926549f)
-rw-r--r--package/system/procd/Makefile2
-rw-r--r--package/system/procd/files/hotplug.json1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 9e829a2159..d0576c1259 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/procd.git
diff --git a/package/system/procd/files/hotplug.json b/package/system/procd/files/hotplug.json
index b930b307a4..9fecddae6b 100644
--- a/package/system/procd/files/hotplug.json
+++ b/package/system/procd/files/hotplug.json
@@ -11,6 +11,7 @@
[ "eq", "DEVNAME", "null" ],
[
[ "makedev", "/dev/%DEVNAME%", "0666" ],
+ [ "exec", "/bin/ln", "-s", "/proc/self/fd", "/dev/fd" ],
[ "exec", "/bin/ln", "-s", "/proc/self/fd/0", "/dev/stdin" ],
[ "exec", "/bin/ln", "-s", "/proc/self/fd/1", "/dev/stdout" ],
[ "exec", "/bin/ln", "-s", "/proc/self/fd/2", "/dev/stderr" ],