summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2023-10-27 00:15:58 +0200
committerJo-Philipp Wich <jo@mein.io>2023-11-02 10:38:48 +0100
commitb5498808155b73ede2a1e8fc3cd4b090bd31788d (patch)
tree28728da1785ae01919de0de6b1984b7551c44ef2
parent41f27bbb6d0af2f37098b97cd28d5f514a6fc417 (diff)
downloadopenwrt-b5498808155b73ede2a1e8fc3cd4b090bd31788d.tar.gz
openwrt-b5498808155b73ede2a1e8fc3cd4b090bd31788d.tar.bz2
openwrt-b5498808155b73ede2a1e8fc3cd4b090bd31788d.zip
ucode: update to latest Git HEAD
- Introduces signal handling facilities - Fixes potentially incorrect object equality tests - Introduces debug library - Introduces log library - ABI version bump due to changed VM structure layout - Revised packaging Changelog: 07c0317 jsdoc: switch to own custom theme 6ca08b0 jsdoc: properly handle indented documentation blocks 2a67f22 lib: add/improve documentation for require(), loadfile(), loadstring() 9993ccb uci: fix potential memory leaks in `configs()` f56394f ci: re-trigger workflows on pull request pushes 1c18993 lib: various documentation fixes d25dcb1 uci: add module documentation 4a8ece2 docs: use CSS and local JavaScript fixups to improve formatting 8f21cfa lib: introduce log library 8a3aefe build: auto-enable module depending on present libraries 6a01adc build: convert CMakeLists.txt into lowercase 8700665 ci: don't skip pull request workflows for `master` branch 0184d23 include: fix execvpe compat function on macOS 8b23884 uloop: rename environ variable to avoid clashing with system macro on macOS 7c209d7 types: ensure double serializatiion with decimal places d150425 rtnl: update the link attr TODOs d394174 rtnl: add IFLA_TARGET_NETNSID for operating in other namespaces 1227733 lib: fix documented return value for `splice()` c9982de docs: add struct module documentation 7dde493 docs: add missing headline to debug module documentation 8f852ea types: improve comparison reliability of binary strings 6940c28 lib: introduce debug library be07107 treewide: consolidate platform specific code in platform.c 2593270 uloop: interrupt on VM signals 97a5292 lib: add `signal()` stdlib function 1dbbb6a main: enable signal dispatching in the standalone cli interpreter 1623245 types: treat signal handler array as GC root 29b1c0d vm: introduce basic signal handling infrastructure 093684d fs: explicitly compare isatty() result 4f4f38f types: don't rely on implicit type conversion in ucv_compare() 4bee0ef docs: disable GitHub Jekyll post processing 5efb7a0 docs: further rework 33bc7bf docs: fix markup quirks 9d5e420 docs: add information about memory management and operator precedence f1190ef docs: various improvements f0cc841 fs: use `fseeko()` and `ftello()` cba0c3c fs: complete function documentation coverage f9260f7 github: drop superfluous CNAME file c85bc74 Create CNAME 5309294 lib: add JSDoc documentation b0f2f90 fs: add JSDoc documentation fe086da math: add JSDoc documentation 70f9348 docs: add initial JSDoc infrastructure 24f1a56 source: fix source offset accounting 9df9160 lexer: don't count EOF token as newline b9d8f06 ci: switch to official openwrt/gh-action-sdk Signed-off-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit eacc885816fb46bf4054b0c3dd2cd1513322ad09)
-rw-r--r--package/utils/ucode/Makefile211
1 files changed, 66 insertions, 145 deletions
diff --git a/package/utils/ucode/Makefile b/package/utils/ucode/Makefile
index e2fe4c8bad..c2f0607341 100644
--- a/package/utils/ucode/Makefile
+++ b/package/utils/ucode/Makefile
@@ -12,13 +12,13 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=https://github.com/jow-/ucode.git
-PKG_SOURCE_DATE:=2023-06-06
-PKG_SOURCE_VERSION:=c7d84aae09691a99ae3db427c0b2463732ef84f4
-PKG_MIRROR_HASH:=38826ae70d886d1d7ada3fc6591ac807169aa28107f60f7f2e617520083525fb
+PKG_SOURCE_DATE:=2023-10-19
+PKG_SOURCE_VERSION:=07c03173d4e6a30953f92fa88ed29b0b956c9106
+PKG_MIRROR_HASH:=fd770335f442ebfc0f4e28d94bb60d886c43aa239ab88e965be7c490b3283a82
PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKG_LICENSE:=ISC
-PKG_ABI_VERSION:=20220812
+PKG_ABI_VERSION:=20230711
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
@@ -35,7 +35,9 @@ CMAKE_HOST_OPTIONS += \
-DSTRUCT_SUPPORT=ON \
-DUBUS_SUPPORT=OFF \
-DUCI_SUPPORT=OFF \
- -DULOOP_SUPPORT=OFF
+ -DULOOP_SUPPORT=OFF \
+ -DDEBUG_SUPPORT=ON \
+ -DLOG_SUPPORT=OFF
define Package/ucode/default
@@ -70,105 +72,29 @@ define Package/libucode/description
The libucode package provides the shared runtime library for the ucode interpreter.
endef
+# 1: name
+# 2: cmake symbol
+# 3: depends
+# 4: description
+define UcodeModule
+ UCODE_MODULES += ucode-mod-$(strip $(1))
+ CMAKE_OPTIONS += -D$(strip $(2))=$(if $(CONFIG_PACKAGE_ucode-mod-$(strip $(1))),ON,OFF)
+ PKG_CONFIG_DEPENDS += CONFIG_PACKAGE_ucode-mod-$(strip $(1))
-define Package/ucode-mod-fs
+ define Package/ucode-mod-$(strip $(1))
$(Package/ucode/default)
- TITLE+= (filesystem module)
- DEPENDS:=ucode
-endef
-
-define Package/ucode-mod-fs/description
- The filesystem plugin module allows interaction with the local file system.
-endef
-
-
-define Package/ucode-mod-math
- $(Package/ucode/default)
- TITLE+= (math module)
- DEPENDS:=ucode
-endef
-
-define Package/ucode-mod-math/description
- The math plugin provides access to various <math.h> procedures.
-endef
-
-
-define Package/ucode-mod-nl80211
- $(Package/ucode/default)
- TITLE+= (nl80211 module)
- DEPENDS:=ucode +libnl-tiny +libubox
-endef
-
-define Package/ucode-mod-nl80211/description
- The nl80211 plugin provides access to the Linux wireless 802.11 netlink API.
-endef
-
-
-define Package/ucode-mod-resolv
- $(Package/ucode/default)
- TITLE+= (resolv module)
- DEPENDS:=ucode
-endef
-
-define Package/ucode-mod-resolv/description
- The resolv plugin implements simple DNS resolving.
-endef
-
-
-define Package/ucode-mod-rtnl
- $(Package/ucode/default)
- TITLE+= (rtnl module)
- DEPENDS:=ucode +libnl-tiny +libubox
-endef
-
-define Package/ucode-mod-rtnl/description
- The rtnl plugin provides access to the Linux routing netlink API.
-endef
-
-
-define Package/ucode-mod-struct
- $(Package/ucode/default)
- TITLE+= (struct module)
- DEPENDS:=ucode
-endef
-
-define Package/ucode-mod-struct/description
- The struct plugin implements Python 3 compatible struct.pack/unpack functionality.
-endef
-
-
-define Package/ucode-mod-ubus
- $(Package/ucode/default)
- TITLE+= (ubus module)
- DEPENDS:=ucode +libubus +libblobmsg-json
-endef
-
-define Package/ucode-mod-ubus/description
- The ubus module allows ucode template scripts to enumerate and invoke ubus
- procedures.
-endef
+ TITLE+= ($(strip $(1)) module)
+ DEPENDS:=ucode $(3)
+ endef
+ define Package/ucode-mod-$(strip $(1))/description
+ $(strip $(4))
+ endef
-define Package/ucode-mod-uci
- $(Package/ucode/default)
- TITLE+= (uci module)
- DEPENDS:=ucode +libuci
-endef
-
-define Package/ucode-mod-uci/description
- The uci module allows templates to read and modify uci configuration.
-endef
-
-
-define Package/ucode-mod-uloop
- $(Package/ucode/default)
- TITLE+= (uloop module)
- DEPENDS:=ucode +libubox
-endef
-
-define Package/ucode-mod-uloop/description
- The uloop module allows ucode scripts to interact with OpenWrt uloop event
- loop implementation.
+ define Package/ucode-mod-$(strip $(1))/install
+ $(INSTALL_DIR) $$(1)/usr/lib/ucode
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/$(strip $(1)).so $$(1)/usr/lib/ucode/
+ endef
endef
@@ -189,60 +115,55 @@ define Package/libucode/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libucode.so.* $(1)/usr/lib/
endef
-define Package/ucode-mod-fs/install
- $(INSTALL_DIR) $(1)/usr/lib/ucode
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/fs.so $(1)/usr/lib/ucode/
-endef
-define Package/ucode-mod-math/install
- $(INSTALL_DIR) $(1)/usr/lib/ucode
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/math.so $(1)/usr/lib/ucode/
-endef
+$(eval $(call UcodeModule, \
+ debug, DEBUG_SUPPORT, +libubox +libucode, \
+ The debug plugin module provides runtime debugging and introspection facilities.))
-define Package/ucode-mod-nl80211/install
- $(INSTALL_DIR) $(1)/usr/lib/ucode
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/nl80211.so $(1)/usr/lib/ucode/
-endef
+$(eval $(call UcodeModule, \
+ fs, FS_SUPPORT, , \
+ The filesystem plugin module allows interaction with the local file system.))
-define Package/ucode-mod-resolv/install
- $(INSTALL_DIR) $(1)/usr/lib/ucode
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/resolv.so $(1)/usr/lib/ucode/
-endef
+$(eval $(call UcodeModule, \
+ log, LOG_SUPPORT, +libubox, \
+ The log plugin module provides access to the syslog and libubox ulog APIs.))
-define Package/ucode-mod-rtnl/install
- $(INSTALL_DIR) $(1)/usr/lib/ucode
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/rtnl.so $(1)/usr/lib/ucode/
-endef
+$(eval $(call UcodeModule, \
+ math, MATH_SUPPORT, , \
+ The math plugin provides access to various <math.h> procedures.))
-define Package/ucode-mod-struct/install
- $(INSTALL_DIR) $(1)/usr/lib/ucode
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/struct.so $(1)/usr/lib/ucode/
-endef
+$(eval $(call UcodeModule, \
+ nl80211, NL80211_SUPPORT, +libnl-tiny +libubox, \
+ The nl80211 plugin provides access to the Linux wireless 802.11 netlink API.))
-define Package/ucode-mod-ubus/install
- $(INSTALL_DIR) $(1)/usr/lib/ucode
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/ubus.so $(1)/usr/lib/ucode/
-endef
+$(eval $(call UcodeModule, \
+ resolv, RESOLV_SUPPORT, , \
+ The resolv plugin implements simple DNS resolving.))
-define Package/ucode-mod-uci/install
- $(INSTALL_DIR) $(1)/usr/lib/ucode
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/uci.so $(1)/usr/lib/ucode/
-endef
+$(eval $(call UcodeModule, \
+ rtnl, RTNL_SUPPORT, +libnl-tiny +libubox, \
+ The rtnl plugin provides access to the Linux routing netlink API.))
-define Package/ucode-mod-uloop/install
- $(INSTALL_DIR) $(1)/usr/lib/ucode
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/ucode/uloop.so $(1)/usr/lib/ucode/
-endef
+$(eval $(call UcodeModule, \
+ struct, STRUCT_SUPPORT, , \
+ The struct plugin implements Python 3 compatible struct.pack/unpack functionality.))
+
+$(eval $(call UcodeModule, \
+ ubus, UBUS_SUPPORT, +libubus +libblobmsg-json, \
+ The ubus module allows ucode template scripts to enumerate and invoke ubus procedures.))
+
+$(eval $(call UcodeModule, \
+ uci, UCI_SUPPORT, +libuci, \
+ The uci module allows templates to read and modify uci configuration.))
+
+$(eval $(call UcodeModule, \
+ uloop, ULOOP_SUPPORT, +libubox, \
+ The uloop module allows ucode scripts to interact with OpenWrt uloop event loop implementation.))
$(eval $(call BuildPackage,libucode))
$(eval $(call BuildPackage,ucode))
-$(eval $(call BuildPackage,ucode-mod-fs))
-$(eval $(call BuildPackage,ucode-mod-math))
-$(eval $(call BuildPackage,ucode-mod-nl80211))
-$(eval $(call BuildPackage,ucode-mod-resolv))
-$(eval $(call BuildPackage,ucode-mod-rtnl))
-$(eval $(call BuildPackage,ucode-mod-struct))
-$(eval $(call BuildPackage,ucode-mod-ubus))
-$(eval $(call BuildPackage,ucode-mod-uci))
-$(eval $(call BuildPackage,ucode-mod-uloop))
+
+$(foreach mod,$(UCODE_MODULES), \
+ $(eval $(call BuildPackage,$(mod))))
+
$(eval $(call HostBuild))