summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2024-03-08 14:43:08 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2024-03-08 14:50:43 +0100
commit2f2eceab1307d9f9c33f151d442ab97c95bd0400 (patch)
tree541d094fbc5ddbc7004d66650883da8df3773270
parent7f1d043b23f6ebf22b345366b430095f2e3ac5db (diff)
downloadopenwrt-2f2eceab1307d9f9c33f151d442ab97c95bd0400.tar.gz
openwrt-2f2eceab1307d9f9c33f151d442ab97c95bd0400.tar.bz2
openwrt-2f2eceab1307d9f9c33f151d442ab97c95bd0400.zip
lantiq: Fix build after kernel 5.15.150
This fixes the following compile problem: ```` CC arch/mips/kernel/vpe-mt.o arch/mips/kernel/vpe-mt.c: In function 'vpe_run': arch/mips/kernel/vpe-mt.c:32:23: error: unused variable 'physical_memsize' [-Werror=unused-variable] 32 | unsigned long physical_memsize = 0L; | ^~~~~~~~~~~~~~~~ cc1: all warnings being treated as errors make[6]: *** [scripts/Makefile.build:289: arch/mips/kernel/vpe-mt.o] Error 1 ```` physical_memsize was removed from upstream kernel, see: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-5.15.y&id=5b4f6c5ff65c8551018ccea40c569afd759734c0 Fixes: 387fde0da0e8 ("kernel: bump 5.15 to 5.15.150") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit 9cfa5f74175d5c663bcf5973024fb76223972033)
-rw-r--r--target/linux/lantiq/patches-5.15/0152-lantiq-VPE.patch12
-rw-r--r--target/linux/lantiq/patches-5.15/0155-lantiq-VPE-nosmp.patch2
2 files changed, 3 insertions, 11 deletions
diff --git a/target/linux/lantiq/patches-5.15/0152-lantiq-VPE.patch b/target/linux/lantiq/patches-5.15/0152-lantiq-VPE.patch
index 00917331c2..2395261ff1 100644
--- a/target/linux/lantiq/patches-5.15/0152-lantiq-VPE.patch
+++ b/target/linux/lantiq/patches-5.15/0152-lantiq-VPE.patch
@@ -67,15 +67,7 @@ Signed-off-by: Stefan Koch <stefan.koch10@gmail.com>
#endif /* _ASM_VPE_H */
--- a/arch/mips/kernel/vpe-mt.c
+++ b/arch/mips/kernel/vpe-mt.c
-@@ -29,6 +29,7 @@ int vpe_run(struct vpe *v)
- struct vpe_notifications *notifier;
- unsigned int vpeflags;
- struct tc *t;
-+ unsigned long physical_memsize = 0L;
-
- /* check we are the Master VPE */
- local_irq_save(flags);
-@@ -415,6 +416,8 @@ int __init vpe_module_init(void)
+@@ -415,6 +415,8 @@ int __init vpe_module_init(void)
}
v->ntcs = hw_tcs - aprp_cpu_index();
@@ -84,7 +76,7 @@ Signed-off-by: Stefan Koch <stefan.koch10@gmail.com>
/* add the tc to the list of this vpe's tc's. */
list_add(&t->tc, &v->tc);
-@@ -518,3 +521,47 @@ void __exit vpe_module_exit(void)
+@@ -518,3 +520,47 @@ void __exit vpe_module_exit(void)
release_vpe(v);
}
}
diff --git a/target/linux/lantiq/patches-5.15/0155-lantiq-VPE-nosmp.patch b/target/linux/lantiq/patches-5.15/0155-lantiq-VPE-nosmp.patch
index 015acabcfe..6426ee717b 100644
--- a/target/linux/lantiq/patches-5.15/0155-lantiq-VPE-nosmp.patch
+++ b/target/linux/lantiq/patches-5.15/0155-lantiq-VPE-nosmp.patch
@@ -10,7 +10,7 @@ Signed-off-by: Stefan Koch <stefan.koch10@gmail.com>
--- a/arch/mips/kernel/vpe-mt.c
+++ b/arch/mips/kernel/vpe-mt.c
-@@ -131,7 +131,10 @@ int vpe_run(struct vpe *v)
+@@ -130,7 +130,10 @@ int vpe_run(struct vpe *v)
* kernels need to turn it on, even if that wasn't the pre-dvpe() state.
*/
#ifdef CONFIG_SMP