summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2024-03-04 23:45:15 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2024-03-04 23:59:24 +0100
commita527b34390f1cbe9b0bcffbc3b6e4e0059b0e251 (patch)
tree9cf2c67fc7df43426f555e19eb208dcea8043446
parente87be1bc0e024040cc452f1e4ae956a1204f6f70 (diff)
downloadopenwrt-a527b34390f1cbe9b0bcffbc3b6e4e0059b0e251.tar.gz
openwrt-a527b34390f1cbe9b0bcffbc3b6e4e0059b0e251.tar.bz2
openwrt-a527b34390f1cbe9b0bcffbc3b6e4e0059b0e251.zip
build: do not depend on $(STAGING_DIR)/.prepared when in SDK
The dependency can't be satisfied when building using the SDK, breaking package builds. As the staging and bin dirs are distributed with the SDK archive, ignoring the dependency is fine when SDK is set. Fixes: fbb924abff8a ("build: add $(STAGING_DIR) and $(BIN_DIR) ...") Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> (cherry picked from commit 2b46cbef8179b4a131bd008c520339441bc87c97)
-rw-r--r--package/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/Makefile b/package/Makefile
index 4663b41de4..d72ce09a81 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -59,6 +59,7 @@ $(curdir)/merge-index: $(curdir)/merge
(cd $(PACKAGE_DIR_ALL) && $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages; )
ifndef SDK
+ $(curdir)//compile = $(STAGING_DIR)/.prepared $(BIN_DIR)
$(curdir)/compile: $(curdir)/system/opkg/host/compile
endif
@@ -117,8 +118,6 @@ endif
$(curdir)/flags-install:= -j1
-$(curdir)//compile = $(STAGING_DIR)/.prepared $(BIN_DIR)
-
$(eval $(call stampfile,$(curdir),package,prereq,.config))
$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
$(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))