summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2024-03-03 15:22:54 +0000
committerDaniel Golle <daniel@makrotopia.org>2024-03-03 16:18:02 +0000
commitc8898f46f9d35b2b5a82a689a3d87f9afe517c50 (patch)
tree793d54c465bc46de0cea50f694f045ee3b694e89
parent37c2bc4397c1f7152ab9cb2f4235cb65a6d501bb (diff)
downloadopenwrt-c8898f46f9d35b2b5a82a689a3d87f9afe517c50.tar.gz
openwrt-c8898f46f9d35b2b5a82a689a3d87f9afe517c50.tar.bz2
openwrt-c8898f46f9d35b2b5a82a689a3d87f9afe517c50.zip
kernel: lantiq: ltq-vmmc: introduce user group for vmmc
asterisk-chan-lantiq is by now the only user of the VMMC interface. And asterisk runs as user 'asterisk' which doesn't give it permission to open the /dev/vmmc* devices. Introduce a new user group 'vmmc' and give permission to access the /dev/vmmc* devices to that group. Another commit for asterisk-chan-lantiq will add the 'asterisk' user to that group. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit 37bbed6f95856a507d727ffc863b20f8a8b35332)
-rw-r--r--package/kernel/lantiq/ltq-vmmc/Makefile1
-rw-r--r--package/kernel/lantiq/ltq-vmmc/files/vmmc.init1
2 files changed, 2 insertions, 0 deletions
diff --git a/package/kernel/lantiq/ltq-vmmc/Makefile b/package/kernel/lantiq/ltq-vmmc/Makefile
index c96cee819b..4972f1c374 100644
--- a/package/kernel/lantiq/ltq-vmmc/Makefile
+++ b/package/kernel/lantiq/ltq-vmmc/Makefile
@@ -29,6 +29,7 @@ define KernelPackage/ltq-vmmc
DEPENDS:=@(TARGET_lantiq_xway||TARGET_lantiq_xrx200) +kmod-ltq-tapi
FILES:=$(PKG_BUILD_DIR)/src/drv_vmmc.ko
AUTOLOAD:=$(call AutoProbe,drv_vmmc)
+ USERID:=:vmmc=386
endef
define KernelPackage/ltq-vmmc/description
diff --git a/package/kernel/lantiq/ltq-vmmc/files/vmmc.init b/package/kernel/lantiq/ltq-vmmc/files/vmmc.init
index 402376e294..78efe80b98 100644
--- a/package/kernel/lantiq/ltq-vmmc/files/vmmc.init
+++ b/package/kernel/lantiq/ltq-vmmc/files/vmmc.init
@@ -8,6 +8,7 @@ start() {
for i in 10 11 12 13 14 15 16 17 18; do
if ! [ -e /dev/vmmc$i ]; then
mknod -m 664 /dev/vmmc$i c 122 $i
+ chown root:vmmc /dev/vmmc$i
fi
done
}