summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2021-03-03 19:48:55 +0100
committerPetr Štetiar <ynezz@true.cz>2021-03-03 22:51:39 +0100
commit13069b1a1dcbef0bb9b42db98025fa9203283220 (patch)
treee39bfe142702b1d9bb02b1011bf378642445a96e
parent1f5e7224868109a170a9248d18f8d2b6124e9c5a (diff)
downloadopenwrt-13069b1a1dcbef0bb9b42db98025fa9203283220.tar.gz
openwrt-13069b1a1dcbef0bb9b42db98025fa9203283220.tar.bz2
openwrt-13069b1a1dcbef0bb9b42db98025fa9203283220.zip
build: add which command to build requirements
`which` utility is not shipped by default for example on recent Arch Linux and then any steps relying on its presence fails, like for example following Python3 prereq build check: $ python3 --version Python 3.9.1 $ make /bin/sh: line 1: which: command not found ... Checking 'python3'... failed. So make `which` utility host build requirement. References: PR#3820 FS#3525 Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--README.md2
-rw-r--r--include/prereq-build.mk3
2 files changed, 4 insertions, 1 deletions
diff --git a/README.md b/README.md
index cb4b043655..68063d9f86 100644
--- a/README.md
+++ b/README.md
@@ -26,7 +26,7 @@ documentation.
```
gcc-6+ binutils bzip2 flex python3 perl make4.1+ find grep diff unzip gawk getopt
-subversion libz-dev libc-dev rsync
+subversion libz-dev libc-dev rsync which
```
### Quickstart
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index bbeba3f8ff..32edc6e437 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -166,6 +166,9 @@ $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
$(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
rsync --version </dev/null))
+$(eval $(call SetupHostCommand,which,Please install 'which', \
+ which which | grep which))
+
$(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
mkdir -p $(dir $@)
$(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<